summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2019-08-14 11:31:29 -0400
committerArmin Kuster <akuster808@gmail.com>2019-09-08 08:31:14 -0700
commitef7a387c8045af08e5db171e944656b9bf15f598 (patch)
tree8c028126a6d0855ec49865196c5f80cc6e3c4679
parent6b4c4fbaef8b4655efbc542fb7b97081dbaed8ce (diff)
downloadopenembedded-core-ef7a387c8045af08e5db171e944656b9bf15f598.tar.gz
kernel-devsrc: tweak for v5.3+
The 5.3 kernel has two changes that require tweaks to the minimal kernel-devsrc package. - 4ce97317f [x86/purgatory: Do not use __builtin_memcpy and __builtin_memset] This change removes the need for arch/x86/purgatory/string.c and instead reuses a copy in arch/x86/boot/compressed/, so we can't copy the file anymore. To support older kernels, we make the copy survive the non-existence of the file. - b1663d7e [docs: Kbuild/Makefile: allow check for missing docs at build time] This change adds the sourceing of Documentation/Kbuild to the top level Kbuild file. So we now leave the copy of Documention/'s Kbuild in the devsrc. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-kernel/linux/kernel-devsrc.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-kernel/linux/kernel-devsrc.bb b/meta/recipes-kernel/linux/kernel-devsrc.bb
index 5ec5929735..3900489ac5 100644
--- a/meta/recipes-kernel/linux/kernel-devsrc.bb
+++ b/meta/recipes-kernel/linux/kernel-devsrc.bb
@@ -65,7 +65,6 @@ do_install() {
)
# then drop all but the needed Makefiles/Kconfig files
- rm -rf $kerneldir/build/Documentation
rm -rf $kerneldir/build/scripts
rm -rf $kerneldir/build/include
@@ -205,11 +204,12 @@ do_install() {
cp -a --parents arch/x86/purgatory/sha256.c $kerneldir/build/ 2>/dev/null || :
cp -a --parents arch/x86/purgatory/stack.S $kerneldir/build/
- cp -a --parents arch/x86/purgatory/string.c $kerneldir/build/
+ cp -a --parents arch/x86/purgatory/string.c $kerneldir/build/ 2>/dev/null || :
cp -a --parents arch/x86/purgatory/setup-x86_64.S $kerneldir/build/
cp -a --parents arch/x86/purgatory/entry64.S $kerneldir/build/
cp -a --parents arch/x86/boot/string.h $kerneldir/build/
cp -a --parents arch/x86/boot/string.c $kerneldir/build/
+ cp -a --parents arch/x86/boot/compressed/string.c $kerneldir/build/ 2>/dev/null || :
cp -a --parents arch/x86/boot/ctype.h $kerneldir/build/
fi