summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2019-06-13 08:17:34 +0000
committerArmin Kuster <akuster808@gmail.com>2019-06-14 07:05:34 -0700
commit99df89a2ee7fb4c896224b68ffbe0aad03c39601 (patch)
tree6526117389cf4d0846f068cf2b9b7909e87f9377
parent48be24d80989e03ad84f4f9d0c8ff51b1f6c070b (diff)
downloadopenembedded-core-99df89a2ee7fb4c896224b68ffbe0aad03c39601.tar.gz
bc: use u-a for bc as well
* bc can be provided by busybox as well (e.g. if you have your own defconfig and forget to explicitly disable it: ... * * Miscellaneous Utilities * adjtimex (4.7 kb) (ADJTIMEX) [N/y/?] n bbconfig (9.7 kb) (BBCONFIG) [N/y/?] n bc (45 kb) (BC) [Y/n/?] (NEW) dc (36 kb) (DC) [Y/n/?] y Use bc code base for dc (larger, more features) (FEATURE_DC_BIG) [Y] (NEW) y Interactive mode (+4kb) (FEATURE_BC_INTERACTIVE) [Y/n/?] (NEW) Enable bc/dc long options (FEATURE_BC_LONG_OPTIONS) [Y/n] (NEW) beep (2.4 kb) (BEEP) [N/y/?] n chat (6.3 kb) (CHAT) [N/y/?] n conspy (10 kb) (CONSPY) [N/y/?] n ... ), causing conflict in u-a: update-alternatives: Error: not linking /usr/bin/bc to /bin/busybox.nosuid since /usr/bin/bc exists and is not a link and then whole do_rootfs or do_populate_sdk to fail because busybox postinst is failing: do_populate_sdk: Postinstall scriptlets of ['busybox'] have failed. If the intention is to defer them to first boot, then please place them into pkg_postinst_ontarget_${PN} (). Deferring to first boot via 'exit 1' is no longer supported. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-extended/bc/bc_1.07.1.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-extended/bc/bc_1.07.1.bb b/meta/recipes-extended/bc/bc_1.07.1.bb
index e80857745e..809b864c1a 100644
--- a/meta/recipes-extended/bc/bc_1.07.1.bb
+++ b/meta/recipes-extended/bc/bc_1.07.1.bb
@@ -27,7 +27,7 @@ do_compile_prepend() {
cp -f ${WORKDIR}/libmath.h ${B}/bc/libmath.h
}
-ALTERNATIVE_${PN} = "dc"
+ALTERNATIVE_${PN} = "bc dc"
ALTERNATIVE_PRIORITY = "100"
-BBCLASSEXTEND = "native" \ No newline at end of file
+BBCLASSEXTEND = "native"