summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2019-03-28 10:21:39 +0000
committerArmin Kuster <akuster808@gmail.com>2019-05-02 13:33:32 -0700
commit16c50cf4cd6a9a11ff47d0825e43f287f1fb2642 (patch)
tree3506047e7e29471ca8b5bf3944be410bdfea2c8d
parentd35de5383275a5d83317160ce3dc09a20661a572 (diff)
downloadopenembedded-core-16c50cf4cd6a9a11ff47d0825e43f287f1fb2642.tar.gz
glibc: always use bfd linker
* Work around broken ld-2.29.so when gold is used causing qemu-arm to segfault during e.g. gobject-introspection or postinst at do_rootfs time, more details in: http://lists.openembedded.org/pipermail/openembedded-devel/2019-March/198937.html https://sourceware.org/bugzilla/show_bug.cgi?id=24148 https://sourceware.org/bugzilla/show_bug.cgi?id=10937 https://sourceware.org/bugzilla/show_bug.cgi?id=18103 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-core/glibc/glibc_2.29.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.29.bb b/meta/recipes-core/glibc/glibc_2.29.bb
index 9184c5932c..073d1533e3 100644
--- a/meta/recipes-core/glibc/glibc_2.29.bb
+++ b/meta/recipes-core/glibc/glibc_2.29.bb
@@ -110,7 +110,7 @@ do_configure () {
do_compile () {
# -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
- unset LDFLAGS
+ LDFLAGS="-fuse-ld=bfd"
base_do_compile
echo "Adjust ldd script"
if [ -n "${RTLDLIST}" ]