summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@kernel.crashing.org>2020-02-25 11:49:29 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-28 23:08:11 +0000
commitc4fb899b19a905a2b027f33947b6ec56f55b81a6 (patch)
tree99026cc59754138b821996d3ff2fcc1d3448a9be
parent7a9d9a4b5fb80a4b22b711c50ddcbd526c0955fb (diff)
downloadopenembedded-core-c4fb899b19a905a2b027f33947b6ec56f55b81a6.tar.gz
sysvinit: Fix install order/dependency
It is possible for sysvinit to be installed before the passwd/group files are installed from base-passwd. This results in an warning that the shutdown group can't be found. Adding a dependeny on base-passwd will resolve this issue. This has similar symptoms to the problem that oe-core commit 0227e929021263c51d2e7db36224000fecb01f1c fixed. The fix is simular in that it ensures that base-passwd is installed first, just at runtime vs setscene time. Signed-off-by: Mark Hatle <mark.hatle@kernel.crashing.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/sysvinit/sysvinit_2.96.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/sysvinit/sysvinit_2.96.bb b/meta/recipes-core/sysvinit/sysvinit_2.96.bb
index 21ef0e9cf3..63c10848b4 100644
--- a/meta/recipes-core/sysvinit/sysvinit_2.96.bb
+++ b/meta/recipes-core/sysvinit/sysvinit_2.96.bb
@@ -70,7 +70,7 @@ FILES_${PN} += "${base_sbindir}/* ${base_bindir}/*"
FILES_sysvinit-pidof = "${base_bindir}/pidof.sysvinit ${base_sbindir}/killall5"
FILES_sysvinit-sulogin = "${base_sbindir}/sulogin.sysvinit"
-RDEPENDS_${PN} += "sysvinit-pidof initd-functions"
+RDEPENDS_${PN} += "sysvinit-pidof initd-functions base-passwd"
CFLAGS_prepend = "-D_GNU_SOURCE "
export LCRYPT = "-lcrypt"