summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMariano Lopez <mariano.lopez@linux.intel.com>2016-08-03 13:21:30 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-10 09:36:23 +0100
commitc52a7e910a3a52a7455a2409d9ade449bbbd66d4 (patch)
tree67c463ab024de5112096590ddab3875e03dde498
parent6b91338a0c09e117cfc58084b66ffcd149765316 (diff)
downloadopenembedded-core-c52a7e910a3a52a7455a2409d9ade449bbbd66d4.tar.gz
python-smartpm_git.bb: Add patch for debugging random errors
This will add a patch to debug random errors seen in the autobuilders, it won't solve the errors, but will give us a better idea of what is happening. [YOCTO #8383] Signed-off-by: Mariano Lopez <mariano.lopez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/python/python-smartpm/smart-add-deugging-when-targetpath-is-empty.patch47
-rw-r--r--meta/recipes-devtools/python/python-smartpm_git.bb1
2 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-smartpm/smart-add-deugging-when-targetpath-is-empty.patch b/meta/recipes-devtools/python/python-smartpm/smart-add-deugging-when-targetpath-is-empty.patch
new file mode 100644
index 0000000000..5e80804bf4
--- /dev/null
+++ b/meta/recipes-devtools/python/python-smartpm/smart-add-deugging-when-targetpath-is-empty.patch
@@ -0,0 +1,47 @@
+From 01e51afd03131947f8d74b9a23fdbc0078249499 Mon Sep 17 00:00:00 2001
+From: Mariano Lopez <mariano.lopez@linux.intel.com>
+Date: Wed, 3 Aug 2016 07:47:09 +0000
+Subject: [PATCH] fetcher.py: Add debugging when targetpath is empty
+
+There are several errors when openining files or manipulating
+path strings, those errors point targetpath passed to
+setSucceeded() is empty. This patch won't solve the problems,
+but will add debugging to give an idea why is failing.
+
+Upstream-Status: Inappropriate [debugging]
+
+Signed-off-by: Mariano Lopez <mariano.lopez@linux.intel.com>
+---
+ smart/fetcher.py | 16 ++++++++++++++++
+ 1 file changed, 16 insertions(+)
+
+diff --git a/smart/fetcher.py b/smart/fetcher.py
+index dd3ff6b..64aa979 100644
+--- a/smart/fetcher.py
++++ b/smart/fetcher.py
+@@ -594,6 +594,22 @@ class FetchItem(object):
+ self._eta = None
+
+ def setSucceeded(self, targetpath, fetchedsize=0):
++ # It seems the in some odd cases targetpath here
++ # is empty, this will lead to bugs in several places
++ if not targetpath:
++ import traceback
++ tb_str = ""
++ for threadId, stack in sys._current_frames().items():
++ tb_str += '\nThreadID: %s' % threadId
++ for filename, lineno, name, line in traceback.extract_stack(stack):
++ tb_str += '\nFile: "%s", line %d, in %s' % (filename, lineno, name)
++ if line:
++ tb_str += "\n %s" % line.strip()
++ error_string = ["No file path specified",
++ "URL: %s" % self._url,
++ "Status: %s" % self._status,
++ "Traceback: %s" % tb_str]
++ raise Error, _("\n".join(error_string))
+ if self._status is not FAILED:
+ self._status = SUCCEEDED
+ self._targetpath = targetpath
+--
+2.6.6
+
diff --git a/meta/recipes-devtools/python/python-smartpm_git.bb b/meta/recipes-devtools/python/python-smartpm_git.bb
index 81e45b7aff..668d171a58 100644
--- a/meta/recipes-devtools/python/python-smartpm_git.bb
+++ b/meta/recipes-devtools/python/python-smartpm_git.bb
@@ -25,6 +25,7 @@ SRC_URI = "\
file://smart-channel-remove-all.patch \
file://smart-locale.patch \
file://smartpm-rpm5-support-check-signatures.patch \
+ file://smart-add-deugging-when-targetpath-is-empty.patch \
"
SRCREV = "407a7eca766431257dcd1da15175cc36a1bb22d0"