aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorXulin Sun <xulin.sun@windriver.com>2019-01-29 15:31:22 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-25 22:25:06 +0000
commiteb875a7ecb74a9a63d81c64ec770ec65ed5d0211 (patch)
treec24718f8dfafe40942f453d963293b3cdc2a2c39
parentfcc56a2e2689a1574b9b928f8cd53e28721e4b9f (diff)
downloadopenembedded-core-eb875a7ecb74a9a63d81c64ec770ec65ed5d0211.tar.gz
openssl: fix multilib file install conflicts
To avoid issue like below if run "bitbake lib32-core-image-minimal" with series userspace packages(LAMP,krb5...) added. Add multilib_script support for openssl's c_rehash which is a perl script. Error: Transaction check error: file /usr/bin/c_rehash conflicts between attempted installs of lib32-openssl-bin-1.1.1-r0.armv7at2hf_neon and openssl-bin-1.1.1-r0.aarch64 (From OE-Core rev: a4032f3cc5de451f0e97eca1f0cbe4a310e1560b) Signed-off-by: Xulin Sun <xulin.sun@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.1.1a.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.1.1a.bb b/meta/recipes-connectivity/openssl/openssl_1.1.1a.bb
index 0fc385fc14..e9e9facd34 100644
--- a/meta/recipes-connectivity/openssl/openssl_1.1.1a.bb
+++ b/meta/recipes-connectivity/openssl/openssl_1.1.1a.bb
@@ -204,3 +204,7 @@ RREPLACES_openssl-conf = "openssl10-conf"
RCONFLICTS_openssl-conf = "openssl10-conf"
BBCLASSEXTEND = "native nativesdk"
+
+inherit multilib_script
+
+MULTILIB_SCRIPTS = "${PN}-bin:${bindir}/c_rehash"