aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2017-11-15 10:54:09 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-04 17:14:36 +0000
commit7484c62f88311dbc1e9ade524af31d04e6035bf4 (patch)
treedf5f6459772c804c5ad72b898cdba3935c90d79a
parente0b8eafaf378571a99b07c559d07f9af36db791e (diff)
downloadopenembedded-core-7484c62f88311dbc1e9ade524af31d04e6035bf4.tar.gz
nss: pay attention to CFLAGS
nss ignores CFLAGS so we suggest them via CC. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> (cherry picked from commit 95b65eefe7eb001752a37d1015bbf9be63bfd6bb) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-support/nss/nss_3.31.1.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-support/nss/nss_3.31.1.bb b/meta/recipes-support/nss/nss_3.31.1.bb
index 588708fc31..2bb9bdb0c6 100644
--- a/meta/recipes-support/nss/nss_3.31.1.bb
+++ b/meta/recipes-support/nss/nss_3.31.1.bb
@@ -104,7 +104,12 @@ do_compile() {
# We can modify CC in the environment, but if we set it via an
# argument to make, nsinstall, a host program, will also build with it!
#
- export CC="${CC} -g"
+ # nss pretty much does its own thing with CFLAGS, so we put them into CC.
+ # Optimization will get clobbered, but most of the stuff will survive.
+ # The motivation for this is to point to the correct place for debug
+ # source files and CFLAGS does that. Nothing uses CCC.
+ #
+ export CC="${CC} ${CFLAGS}"
make -C ./nss CCC="${CXX} -g" \
OS_TEST=${OS_TEST} \
RPATH="${RPATH}"