aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-01-17 12:14:00 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-25 11:36:06 +0000
commit68a3f33027b9ee5ed53a47dd839fc407dcbbaee9 (patch)
tree237ff432196910749d6cb6d38a5cc9f4a7025528
parenta3eb3280cc0f33491cdc478086e4cfcd5ecc52d6 (diff)
downloadopenembedded-core-68a3f33027b9ee5ed53a47dd839fc407dcbbaee9.tar.gz
lz4: remove ptest changes
This recipe installs the test suite by copying the entire build tree into /usr/share/ptest, which is both wasteful and breaks packaging as lz4-ptest then gets renamed by debian.bbclass to liblz4. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-support/lz4/lz4_1.7.4.bb10
1 files changed, 1 insertions, 9 deletions
diff --git a/meta/recipes-support/lz4/lz4_1.7.4.bb b/meta/recipes-support/lz4/lz4_1.7.4.bb
index 9e86985d69..86a1ab9ab9 100644
--- a/meta/recipes-support/lz4/lz4_1.7.4.bb
+++ b/meta/recipes-support/lz4/lz4_1.7.4.bb
@@ -17,19 +17,11 @@ SRC_URI = "git://github.com/lz4/lz4.git \
UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)"
S = "${WORKDIR}/git"
-inherit ptest
-EXTRA_OEMAKE = "PREFIX=${prefix} CC='${CC}' DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir}"
+EXTRA_OEMAKE = "PREFIX=${prefix} CC='${CC}' DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir}"
do_install() {
oe_runmake install
}
-do_install_ptest () {
- install -d ${D}${PTEST_PATH}/testsuite
- cp -rf ${S}/* ${D}${PTEST_PATH}/testsuite
-}
-
-RDEPENDS_${PN}-ptest += "make python3"
-
BBCLASSEXTEND = "native nativesdk"