aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCalifornia Sullivan <california.l.sullivan@intel.com>2017-11-14 14:10:09 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-06 10:11:42 +0000
commit236cb8fe6bb9f5826a97f393b22aaae79dec1b84 (patch)
tree7c86a047367928b170987dbbbdf1443f4dabadcf
parent3dd1862ac0f13ffec06209c80b307c6bc0aa8dc3 (diff)
downloadopenembedded-core-236cb8fe6bb9f5826a97f393b22aaae79dec1b84.tar.gz
initramfs-framework: add install module
The non-EFI counterpart for installation was previously missing for initramfs-framework. This simply puts the normal install script in the correct location for initramfs-framework to make use of it. Partial fix for [YOCTO #12346]. Signed-off-by: California Sullivan <california.l.sullivan@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> (cherry picked from commit f9d7cf30b12cbc5f642a11c0511dc1dc3ccf1aa5) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/conf/layer.conf4
-rw-r--r--meta/recipes-core/initrdscripts/initramfs-module-install_1.0.bb20
2 files changed, 24 insertions, 0 deletions
diff --git a/meta/conf/layer.conf b/meta/conf/layer.conf
index 6be2a57a70..4ba0b9378e 100644
--- a/meta/conf/layer.conf
+++ b/meta/conf/layer.conf
@@ -57,6 +57,10 @@ SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS += " \
initramfs-module-install-efi->e2fsprogs \
initramfs-module-install-efi->parted \
initramfs-module-install-efi->util-linux \
+ initramfs-module-install->e2fsprogs \
+ initramfs-module-install->grub \
+ initramfs-module-install->parted \
+ initramfs-module-install->util-linux \
liberation-fonts->fontconfig \
cantarell-fonts->fontconfig \
gnome-icon-theme->librsvg \
diff --git a/meta/recipes-core/initrdscripts/initramfs-module-install_1.0.bb b/meta/recipes-core/initrdscripts/initramfs-module-install_1.0.bb
new file mode 100644
index 0000000000..ce7f165bfe
--- /dev/null
+++ b/meta/recipes-core/initrdscripts/initramfs-module-install_1.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "initramfs-framework module for installation option"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+RDEPENDS_${PN} = "initramfs-framework-base grub parted e2fsprogs-mke2fs util-linux-blkid"
+
+PR = "r1"
+
+inherit allarch
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+SRC_URI = "file://init-install.sh"
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -d ${D}/init.d
+ install -m 0755 ${WORKDIR}/init-install.sh ${D}/init.d/install.sh
+}
+
+FILES_${PN} = "/init.d/install.sh"