aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrej Valek <andrej.valek@siemens.com>2017-11-23 10:38:58 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-06 10:11:42 +0000
commit009302a350877d0e9b74df4bf0d97fe6244591d5 (patch)
tree7c147bab4d8c2d3dafa4ddf694c63ca2684af14e
parent06cd7db573bb1293ca3baf214c046d7deb5ed058 (diff)
downloadopenembedded-core-009302a350877d0e9b74df4bf0d97fe6244591d5.tar.gz
mtd-utils: fix flash_eraseall installation conflict
override correctly busybox's applet when CONFIG_FLASH_ERASEALL=y is set Error: update-alternatives: not linking /builds/image/1.0-r0/rootfs/usr/ sbin/flash_eraseall to /bin/busybox.nosuid since /builds/image/1.0-r0/ rootfs/usr/sbin/flash_eraseall exists and is not a link Signed-off-by: Andrej Valek <andrej.valek@siemens.com> Signed-off-by: Ross Burton <ross.burton@intel.com> (cherry picked from commit 21d5a52d86a4090f7ddb1a9eb41bb143261f890e) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-devtools/mtd/mtd-utils_git.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-devtools/mtd/mtd-utils_git.bb b/meta/recipes-devtools/mtd/mtd-utils_git.bb
index 4fbc54f8f4..48ba2ee07a 100644
--- a/meta/recipes-devtools/mtd/mtd-utils_git.bb
+++ b/meta/recipes-devtools/mtd/mtd-utils_git.bb
@@ -5,7 +5,7 @@ LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
file://include/common.h;beginline=1;endline=17;md5=ba05b07912a44ea2bf81ce409380049c"
-inherit autotools pkgconfig
+inherit autotools pkgconfig update-alternatives
DEPENDS = "zlib lzo e2fsprogs util-linux"
@@ -30,6 +30,11 @@ PACKAGECONFIG[xattr] = ",,acl,"
EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} ${@bb.utils.contains('PACKAGECONFIG', 'xattr', '', '-DWITHOUT_XATTR', d)} -I${S}/include' 'BUILDDIR=${S}'"
+ALTERNATIVE_${PN} = "flash_eraseall"
+ALTERNATIVE_LINK_NAME[flash_eraseall] = "${sbindir}/flash_eraseall"
+# Use higher priority than busybox's flash_eraseall (created when built with CONFIG_FLASH_ERASEALL)
+ALTERNATIVE_PRIORITY[flash_eraseall] = "100"
+
do_install () {
oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} INCLUDEDIR=${includedir}
}