aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2017-12-24 00:11:03 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-03 08:30:35 +0000
commit79d81cf8404364f0eb17f2726568e4cf027483dd (patch)
treed07aaa00f3696ae7a610a886cf0777ea8d76ba94
parentfbe2b6d3b7eb1911cdaf25e59370cbcc2b4837f6 (diff)
downloadopenembedded-core-79d81cf8404364f0eb17f2726568e4cf027483dd.tar.gz
linux-yocto/4.9: fix aufs build
The aufs4 core code was missing some changes to build against the 4.9 fs subsystem. This commit resyncs with the upstream repo, and we can once again build against 4.9. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> (cherry picked from commit b530ab2d3ab28aded6ec86e6f8a6d9be45532361) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.9.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.9.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.9.bb18
3 files changed, 13 insertions, 13 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.9.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.9.bb
index 4ab444fcbc..5e6f054b55 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.9.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.9.bb
@@ -11,8 +11,8 @@ python () {
raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "56b06caa70f42d31067f33204a89417b3818aa77"
-SRCREV_meta ?= "d15398f64655e36b444d69b3bed43444608abf55"
+SRCREV_machine ?= "c83e63d1a6da1218b61d352a866bc174554f71a9"
+SRCREV_meta ?= "a2dfb1610d9dad34652a3c27c6c9d8751ed67af6"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.9.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.9;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.9.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.9.bb
index 3e67029775..398209ef9a 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.9.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.9.bb
@@ -9,8 +9,8 @@ LINUX_VERSION ?= "4.9.71"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "3061011aade2678733665bccd553fdcd60165671"
-SRCREV_meta ?= "d15398f64655e36b444d69b3bed43444608abf55"
+SRCREV_machine ?= "a87b8d53730b5736575c738390abc498a31ba735"
+SRCREV_meta ?= "a2dfb1610d9dad34652a3c27c6c9d8751ed67af6"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.9.bb b/meta/recipes-kernel/linux/linux-yocto_4.9.bb
index e97355cbca..1fdd7bf1d5 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.9.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.9.bb
@@ -11,15 +11,15 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "0638cb025fd0d8192dbc0acc09018d6fec9f1597"
-SRCREV_machine_qemuarm64 ?= "3061011aade2678733665bccd553fdcd60165671"
-SRCREV_machine_qemumips ?= "a8971e1548188eb07b88896c7f9d590abb92ed98"
-SRCREV_machine_qemuppc ?= "3061011aade2678733665bccd553fdcd60165671"
-SRCREV_machine_qemux86 ?= "3061011aade2678733665bccd553fdcd60165671"
-SRCREV_machine_qemux86-64 ?= "3061011aade2678733665bccd553fdcd60165671"
-SRCREV_machine_qemumips64 ?= "3cff06df7c72b53af99045fcbcdaf2f9285adc1a"
-SRCREV_machine ?= "3061011aade2678733665bccd553fdcd60165671"
-SRCREV_meta ?= "d15398f64655e36b444d69b3bed43444608abf55"
+SRCREV_machine_qemuarm ?= "7e0dc801cf0ab19827fd33214fe6036d80258653"
+SRCREV_machine_qemuarm64 ?= "a87b8d53730b5736575c738390abc498a31ba735"
+SRCREV_machine_qemumips ?= "69371c276be034fff40b5652184401d8dc2262a1"
+SRCREV_machine_qemuppc ?= "a87b8d53730b5736575c738390abc498a31ba735"
+SRCREV_machine_qemux86 ?= "a87b8d53730b5736575c738390abc498a31ba735"
+SRCREV_machine_qemux86-64 ?= "a87b8d53730b5736575c738390abc498a31ba735"
+SRCREV_machine_qemumips64 ?= "b3159328d2dd0c53cf81b702c4f9cd520649c84a"
+SRCREV_machine ?= "a87b8d53730b5736575c738390abc498a31ba735"
+SRCREV_meta ?= "a2dfb1610d9dad34652a3c27c6c9d8751ed67af6"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.9.git;name=machine;branch=${KBRANCH}; \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.9;destsuffix=${KMETA}"