aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2016-12-13 20:00:35 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-09 11:05:55 +0000
commit6017c9b2009357ece12be18550ddfbafe555430a (patch)
tree9d95363b3d67f9880df82cf47d51bb1171f14c6c
parent4e257a7429e1a7525c1939d4f011e938d4ca32b1 (diff)
downloadopenembedded-core-6017c9b2009357ece12be18550ddfbafe555430a.tar.gz
gnu-efi: build 64-bit for x32
We're targeting the x86_64 EFI ABI. (From OE-Core rev: 24325410acb670a3e7bc626ac3607efa8df38dc5) Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-bsp/gnu-efi/gnu-efi_3.0.4.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta/recipes-bsp/gnu-efi/gnu-efi_3.0.4.bb b/meta/recipes-bsp/gnu-efi/gnu-efi_3.0.4.bb
index e0d8ee76dd..8de485c00c 100644
--- a/meta/recipes-bsp/gnu-efi/gnu-efi_3.0.4.bb
+++ b/meta/recipes-bsp/gnu-efi/gnu-efi_3.0.4.bb
@@ -52,3 +52,12 @@ BBCLASSEXTEND = "native"
# CFLAGS += -mno-mmx -mno-sse
# So also remove -mfpmath=sse from TUNE_CCARGS
TUNE_CCARGS_remove = "-mfpmath=sse"
+
+python () {
+ ccargs = d.getVar('TUNE_CCARGS', True).split()
+ if '-mx32' in ccargs:
+ # use x86_64 EFI ABI
+ ccargs.remove('-mx32')
+ ccargs.append('-m64')
+ d.setVar('TUNE_CCARGS', ' '.join(ccargs))
+}