aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThiruvadi Rajaraman <trajaraman@mvista.com>2017-11-04 08:03:33 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-21 14:42:56 +0000
commit3b73976716ee71a8040221f22c5fbda79512a958 (patch)
tree74028eb71ee2e28fca3f0bf0501dffb10dc1f8ab
parent2da99dc9f7f3d8373cc3108c18300723ad4a243a (diff)
downloadopenembedded-core-3b73976716ee71a8040221f22c5fbda79512a958.tar.gz
curl: Security fix for CVE-2016-8617
Affected versions: curl 7.1 to and including 7.50.3 Not affected versions: curl >= 7.51.0 Signed-off-by: Thiruvadi Rajaraman <trajaraman@mvista.com> Signed-off-by: Armin Kuster <akuster@mvista.com>
-rw-r--r--meta/recipes-support/curl/curl/CVE-2016-8617.patch30
-rw-r--r--meta/recipes-support/curl/curl_7.50.1.bb1
2 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl/CVE-2016-8617.patch b/meta/recipes-support/curl/curl/CVE-2016-8617.patch
new file mode 100644
index 0000000000..167f2faee3
--- /dev/null
+++ b/meta/recipes-support/curl/curl/CVE-2016-8617.patch
@@ -0,0 +1,30 @@
+From 32ae8ba41b5dbf26dabe884ac4aa12597d1d96b9 Mon Sep 17 00:00:00 2001
+From: Daniel Stenberg <daniel@haxx.se>
+Date: Wed, 28 Sep 2016 00:05:12 +0200
+Subject: [PATCH] base64: check for integer overflow on large input
+
+Upstream-Status: Backport
+CVE: CVE-2016-8617
+
+Signed-off-by: Thiruvadi Rajaraman <trajaraman@mvista.com>
+
+---
+ lib/base64.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+Index: curl-7.50.1/lib/base64.c
+===================================================================
+--- curl-7.50.1.orig/lib/base64.c 2016-07-21 04:01:36.000000000 +0530
++++ curl-7.50.1/lib/base64.c 2017-06-12 17:06:30.865546695 +0530
+@@ -190,6 +190,11 @@
+ if(!insize)
+ insize = strlen(indata);
+
++#if SIZEOF_SIZE_T == 4
++ if(insize > UINT_MAX/4)
++ return CURLE_OUT_OF_MEMORY;
++#endif
++
+ base64data = output = malloc(insize * 4 / 3 + 4);
+ if(!output)
+ return CURLE_OUT_OF_MEMORY;
diff --git a/meta/recipes-support/curl/curl_7.50.1.bb b/meta/recipes-support/curl/curl_7.50.1.bb
index 9a9741dfe1..ad7d83dac7 100644
--- a/meta/recipes-support/curl/curl_7.50.1.bb
+++ b/meta/recipes-support/curl/curl_7.50.1.bb
@@ -19,6 +19,7 @@ SRC_URI += " file://configure_ac.patch \
file://CVE-2016-8620.patch \
file://CVE-2016-8621.patch \
file://CVE-2016-8623.patch \
+ file://CVE-2016-8617.patch \
"
SRC_URI[md5sum] = "015f6a0217ca6f2c5442ca406476920b"