summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-01-26 11:27:41 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-27 16:38:54 +0000
commitf9259da409c2aa92deb71aef0da2405c8d836615 (patch)
tree854795f6c127161deffc250a3d733baea2c090f2
parentb4f0df9a0e998af746bcd84cb81ea4ba0107f989 (diff)
downloadopenembedded-core-f9259da409c2aa92deb71aef0da2405c8d836615.tar.gz
perf: Pass LDSHARED and CCLD via EXTRA_OEMAKE
python code underneath is smart and pokes at python installation in sysroot for compile environment, the overrides from EXTRA_OEMAKE are ofcourse preferred but it falls back to python3's distutils/sysconfig for rest of them, and it does use CCLD and LDSHARED for linking, when we use clang to compile python3 then it encodes these variables to be clang however, when building perf we inherit kernel which forces gcc to be used for compiling perf, which then mixes both compilers due to CCLD and LDSHARED demands. Therefore override CCLD and LDSHARED in make environment helps python/distutils to use right linker Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/perf/perf.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 840f3008b5..6d1b06693d 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -73,6 +73,8 @@ EXTRA_OEMAKE = '\
CROSS_COMPILE=${TARGET_PREFIX} \
ARCH=${ARCH} \
CC="${CC}" \
+ CCLD="${CC}" \
+ LDSHARED="${CC} -shared" \
AR="${AR}" \
LD="${LD}" \
EXTRA_CFLAGS="-ldw" \