summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2019-07-20 02:12:37 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-07-20 12:05:34 +0100
commitdd8c7f2466d94fd8326b962e9bcfc4f42a35da38 (patch)
tree75d284ea61c21de63165a38f4618b8baa76945f3
parent190531943ab43758f83ff021caef1f68dbdc3840 (diff)
downloadopenembedded-core-dd8c7f2466d94fd8326b962e9bcfc4f42a35da38.tar.gz
psplash: create psplash tmpfs mount directory in psplash-init
The psplash binary uses TMPDIR as directory to store the FIFO to communicate with the psplash tools. This directory can be in any location an init system determines to be suitable, psplash-init uses /mnt/ for it. Rather than creating the mount directory in the recipe, just create it in the init script itself. This allows other init scripts to use a different location without having an unnecessary .psplash directory in /mnt. Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rwxr-xr-xmeta/recipes-core/psplash/files/psplash-init1
-rw-r--r--meta/recipes-core/psplash/psplash_git.bb3
2 files changed, 1 insertions, 3 deletions
diff --git a/meta/recipes-core/psplash/files/psplash-init b/meta/recipes-core/psplash/files/psplash-init
index 0bce1de536..fee23e681c 100755
--- a/meta/recipes-core/psplash/files/psplash-init
+++ b/meta/recipes-core/psplash/files/psplash-init
@@ -24,6 +24,7 @@ for x in $CMDLINE; do
done
export TMPDIR=/mnt/.psplash
+[ -d $TMPDIR ] || mkdir -p $TMPDIR
mount tmpfs -t tmpfs $TMPDIR -o,size=40k
rotation=0
diff --git a/meta/recipes-core/psplash/psplash_git.bb b/meta/recipes-core/psplash/psplash_git.bb
index 3161a5e3f1..56734c1582 100644
--- a/meta/recipes-core/psplash/psplash_git.bb
+++ b/meta/recipes-core/psplash/psplash_git.bb
@@ -97,7 +97,6 @@ python do_compile () {
}
do_install_append() {
- install -d ${D}/mnt/.psplash/
install -d ${D}${sysconfdir}/init.d/
install -m 0755 ${WORKDIR}/psplash-init ${D}${sysconfdir}/init.d/psplash.sh
install -d ${D}${bindir}
@@ -107,8 +106,6 @@ do_install_append() {
rm -f ${D}${bindir}/psplash
}
-FILES_${PN} += "/mnt/.psplash"
-
INITSCRIPT_NAME = "psplash.sh"
INITSCRIPT_PARAMS = "start 0 S . stop 20 0 1 6 ."