summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-03-21 09:20:06 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-03-22 16:24:21 +0000
commitba6435d13f9d565a92d3e6f15a04398c8a7133f6 (patch)
treef50caa624083cfad54774abd0b214d1e537ec250
parent95b01b95a99df06e555416ec4834df426bca4c4a (diff)
downloadopenembedded-core-ba6435d13f9d565a92d3e6f15a04398c8a7133f6.tar.gz
llvm: Upgrade to 18.1.2 bugfix release
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/llvm/llvm_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index 8086c9e2eb..e1d5fc47a1 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -17,14 +17,14 @@ inherit cmake pkgconfig
# could be 'rcX' or 'git' or empty ( for release )
VER_SUFFIX = ""
-PV = "18.1.1${VER_SUFFIX}"
+PV = "18.1.2${VER_SUFFIX}"
MAJOR_VERSION = "${@oe.utils.trim_version("${PV}", 1)}"
LLVM_RELEASE = "${PV}"
BRANCH = "release/${MAJOR_VERSION}.x"
-SRCREV = "dba2a75e9c7ef81fe84774ba5eee5e67e01d801a"
+SRCREV = "26a1d6601d727a96f4301d0d8647b5a42760ae0c"
SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH};protocol=https \
file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \
file://0001-AsmMatcherEmitter-sort-ClassInfo-lists-by-name-as-we.patch;striplevel=2 \