summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-27 21:54:13 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-28 11:11:05 +0000
commit9031b66c7c817b65f75b429db6f6527d07196e8a (patch)
tree6c402597c1aa6021528eea00a30b203283bb8b8c
parent790be4ace4da2e2d7597d4e8ccf75ed7f711184d (diff)
downloadopenembedded-core-9031b66c7c817b65f75b429db6f6527d07196e8a.tar.gz
grep: Fix shell after autotools changes
After changing autotools.bbclass, CONFIG_SHELL setting no longer works resulting in: grep-3.4-r0 do_package_qa: QA Issue: /bin/fgrep.grep contained in package grep requires /bin/bash, but no providers found in RDEPENDS_grep? [file-rdeps] The script can use /bin/sh so set this specifically using sed since we want to use a consistent shell for the rest of the build but not have the specific bash dependency. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/grep/grep_3.4.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/meta/recipes-extended/grep/grep_3.4.bb b/meta/recipes-extended/grep/grep_3.4.bb
index fb8dcec490..e176dd727b 100644
--- a/meta/recipes-extended/grep/grep_3.4.bb
+++ b/meta/recipes-extended/grep/grep_3.4.bb
@@ -16,6 +16,7 @@ inherit autotools gettext texinfo pkgconfig
acpaths = "-I ./m4"
do_configure_prepend () {
+ sed -i -e '1s,#!@SHELL@,#!/bin/sh,' ${S}/src/egrep.sh
rm -f ${S}/m4/init.m4
}
@@ -41,5 +42,3 @@ ALTERNATIVE_${PN} = "grep egrep fgrep"
ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep"
ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep"
ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep"
-
-export CONFIG_SHELL="/bin/sh"