summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2018-01-10 00:09:00 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-11 23:22:43 +0000
commit5f4b54a234ad7a859db8a1e23c6892a8b3bc1b52 (patch)
treeeab0cb0ccf95d1fe2efa71e52de6c96730220856
parentbead76b50dc60e1b6b39fa5b659a7af44ff91adc (diff)
downloadopenembedded-core-5f4b54a234ad7a859db8a1e23c6892a8b3bc1b52.tar.gz
perf: depend on native versions of bison and flex
Explicitly depend on bison-native and flex-native for deterministic builds, as those are required for the build: | Makefile.config:129: *** Error: flex is missing on this system, please install it. Stop. | Makefile.perf:205: recipe for target 'sub-make' failed | make[1]: *** [sub-make] Error 2 | Makefile:68: recipe for target 'all' failed | make: *** [all] Error 2 | Makefile.config:133: *** Error: bison is missing on this system, please install it. Stop. | Makefile.perf:205: recipe for target 'sub-make' failed | make[1]: *** [sub-make] Error 2 | Makefile:68: recipe for target 'all' failed | make: *** [all] Error 2 In most cases, those dependencies come indirectly via toolchain dependencies, specifically binutils-cross, which pulls both bison-native and flex-native. Different setups, such as with external toolchain, would expose this problem, since correct dependency is not marked explicitly. The change is build-tested on all qemu architectures. Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/perf/perf.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index b79b973947..bb943ecd1c 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -26,7 +26,7 @@ DEPENDS = " \
virtual/${MLPREFIX}libc \
${MLPREFIX}elfutils \
${MLPREFIX}binutils \
- bison flex xz \
+ bison-native flex-native xz \
xmlto-native \
asciidoc-native \
"