summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-01-23 18:34:16 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-27 16:38:54 +0000
commit3a3b20df28f6ace6267b68c34faeef3da4d7ef8a (patch)
tree2711ca188128075e0d1ca02b7c505431356d1fb3
parentcd4fc516ce0f8e4c5cadb7a700fe29643ed9128d (diff)
downloadopenembedded-core-3a3b20df28f6ace6267b68c34faeef3da4d7ef8a.tar.gz
elfutils: additional ptest fixes
This should address ARM64 specific failures in particular. eu-objdump is now installed on all architectures; ptests fail in its absence and pass when it is present, so it's useful at least in some scenarios in non-x86 architectures and fails gracefully otherwise. The original decision to exclude it was here: https://bugzilla.yoctoproject.org/show_bug.cgi?id=5283 Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/elfutils/elfutils_0.178.bb7
1 files changed, 2 insertions, 5 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.178.bb b/meta/recipes-devtools/elfutils/elfutils_0.178.bb
index 9393628dd1..8f5deb2c62 100644
--- a/meta/recipes-devtools/elfutils/elfutils_0.178.bb
+++ b/meta/recipes-devtools/elfutils/elfutils_0.178.bb
@@ -58,11 +58,7 @@ RDEPENDS_${PN}-ptest += "libasm libelf bash make coreutils ${PN}-binutils"
EXTRA_OECONF_append_class-target += "--disable-tests-rpath"
-do_install_append() {
- if [ "${TARGET_ARCH}" != "x86_64" ] && [ -z `echo "${TARGET_ARCH}"|grep 'i.86'` ];then
- rm -f ${D}${bindir}/eu-objdump
- fi
-}
+RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-utils"
do_compile_ptest() {
cd ${B}/tests
@@ -139,6 +135,7 @@ INHIBIT_PACKAGE_STRIP_FILES = "\
${PKGD}${PTEST_PATH}/tests/elfstrmerge \
${PKGD}${PTEST_PATH}/tests/backtrace-child \
${PKGD}${PTEST_PATH}/tests/backtrace-data \
+ ${PKGD}${PTEST_PATH}/tests/backtrace-dwarf \
${PKGD}${PTEST_PATH}/tests/deleted \
${PKGD}${PTEST_PATH}/src/strip \
${PKGD}${PTEST_PATH}/src/addr2line \