summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiangyu Chen <xiangyu.chen@windriver.com>2024-04-09 14:58:26 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-23 13:33:46 +0100
commit05107ec5e4b81315d53efef23f2a570d520ee4c7 (patch)
tree35a7f9b39b2c246ab8ef31eeae3e8061879e3f8a
parentbf384d6618780dea2df24adac88ba4364cb65b9b (diff)
downloadopenembedded-core-05107ec5e4b81315d53efef23f2a570d520ee4c7.tar.gz
iputils: splitting the ping6 as a package
The iputils merged the ping4 and ping6 command into the ping since the commit ebad35fe[1], currently, iputils ping support being called using "ping -6" or "ping6" symlinks. In oe-core, there are two packages provide ipv6 ping, inetutils and iputils, the inetutils-ping6 doesn't support "-I" option to bind the interface, that cause some of scripts(e.g. LTP test[2]) which was based on iputils-ping6 fails. If someone or a package needs iputils-ping6, they can enable it in local.conf or add it into rdepends directly. Ref: [1] https://github.com/iputils/iputils/commit/e3de851b809c7b72ccc654a72b6af61d [2] https://github.com/linux-test-project/ltp/blob/master/testcases/kernel/ \ containers/netns/netns_comm.sh#L25 Signed-off-by: Xiangyu Chen <xiangyu.chen@windriver.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
-rw-r--r--meta/recipes-extended/iputils/iputils_20240117.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/meta/recipes-extended/iputils/iputils_20240117.bb b/meta/recipes-extended/iputils/iputils_20240117.bb
index 5a5e15528e..3880689742 100644
--- a/meta/recipes-extended/iputils/iputils_20240117.bb
+++ b/meta/recipes-extended/iputils/iputils_20240117.bb
@@ -35,7 +35,11 @@ ALTERNATIVE_PRIORITY = "100"
ALTERNATIVE:${PN}-ping = "ping"
ALTERNATIVE_LINK_NAME[ping] = "${base_bindir}/ping"
-SPLITPKGS = "${PN}-ping ${PN}-arping ${PN}-tracepath ${PN}-clockdiff"
+ALTERNATIVE:${PN}-ping6 = "ping6"
+ALTERNATIVE_LINK_NAME[ping6] = "${base_bindir}/ping6"
+
+SPLITPKGS = "${PN}-ping ${PN}-arping ${PN}-tracepath ${PN}-clockdiff \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', '${PN}-ping6', '', d)}"
PACKAGES += "${SPLITPKGS}"
ALLOW_EMPTY:${PN} = "1"
@@ -43,6 +47,13 @@ RDEPENDS:${PN} += "${SPLITPKGS}"
FILES:${PN} = ""
FILES:${PN}-ping = "${base_bindir}/ping.${BPN}"
+FILES:${PN}-ping6 = "${base_bindir}/ping6.${BPN}"
FILES:${PN}-arping = "${base_bindir}/arping"
FILES:${PN}-tracepath = "${base_bindir}/tracepath"
FILES:${PN}-clockdiff = "${base_bindir}/clockdiff"
+
+do_install:append() {
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'true', 'false', d)}; then
+ ln -sf ping ${D}/${base_bindir}/ping6
+ fi
+}