summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-27 16:32:59 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-27 16:44:04 +0000
commit037bef5c7dfe82642d19f07b38f6ccc783958e41 (patch)
tree1325830baf60a28cb8040f6b12c8c23c839c385e
parentc139e058bb2df48c79784cf3fd701e51bbc68427 (diff)
downloadopenembedded-core-037bef5c7dfe82642d19f07b38f6ccc783958e41.tar.gz
kbd: Fix build reproducibility issue
Our CFLAGS were being lost which was breaking reproducibile builds due to losee of the debug prefix remapping flags. Fix this. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/kbd/kbd/fix_cflags.patch25
-rw-r--r--meta/recipes-core/kbd/kbd_2.2.0.bb1
2 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-core/kbd/kbd/fix_cflags.patch b/meta/recipes-core/kbd/kbd/fix_cflags.patch
new file mode 100644
index 0000000000..37220960ab
--- /dev/null
+++ b/meta/recipes-core/kbd/kbd/fix_cflags.patch
@@ -0,0 +1,25 @@
+We need to ensure our CFLAGS are preserved as well as whatever tweak configure
+tries to make. Without these, the debug prefix changes get lost and we lose
+build reproducibility, likely with other side effects.
+
+Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
+Upstream-Status: Pending
+2020/1/27
+
+Index: kbd-2.2.0/configure.ac
+===================================================================
+--- kbd-2.2.0.orig/configure.ac
++++ kbd-2.2.0/configure.ac
+@@ -72,9 +72,9 @@ if test "$enable_code_coverage" = yes; t
+ fi
+
+ case "$GCC,$ac_cv_prog_cc_g" in
+- yes,yes) CFLAGS="-g $CC_O_LEVEL $FORTIFY_SOURCE" ;;
+- yes,) CFLAGS="$CC_O_LEVEL $FORTIFY_SOURCE" ;;
+- ,yes) CFLAGS="-g" ;;
++ yes,yes) CFLAGS="-g $CC_O_LEVEL $FORTIFY_SOURCE $CFLAGS" ;;
++ yes,) CFLAGS="$CC_O_LEVEL $FORTIFY_SOURCE $CFLAGS" ;;
++ ,yes) CFLAGS="-g $CFLAGS" ;;
+ esac
+
+ CC_CHECK_CFLAGS_APPEND([\
diff --git a/meta/recipes-core/kbd/kbd_2.2.0.bb b/meta/recipes-core/kbd/kbd_2.2.0.bb
index e13cea7634..e5700ff57f 100644
--- a/meta/recipes-core/kbd/kbd_2.2.0.bb
+++ b/meta/recipes-core/kbd/kbd_2.2.0.bb
@@ -17,6 +17,7 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/utils/${BPN}/${BP}.tar.xz \
${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'file://set-proper-path-of-resources.patch', '', d)} \
file://0001-analyze.l-add-missing-string-format.patch \
file://0001-Use-DATADIR-and-append-i386-to-fix-libkbdfile-test08.patch \
+ file://fix_cflags.patch \
"
SRC_URI[md5sum] = "d1d7ae0b5fb875dc082731e09cd0c8bc"