aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-12-17 07:38:43 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-22 23:42:46 +0000
commitf02a8228db795f2c6c8d81cfd7e0b88bf355c1b8 (patch)
treecf38c945455b7df7036df567cf50ce234ac46ebc
parent8920e520b58118c72c68e739c780efd71c1650d3 (diff)
downloadopenembedded-core-f02a8228db795f2c6c8d81cfd7e0b88bf355c1b8.tar.gz
gdk-pixbuf: Fix latent build issue exposed by musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf/libc_memfuncs.patch63
-rw-r--r--meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.32.1.bb1
2 files changed, 64 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf/libc_memfuncs.patch b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf/libc_memfuncs.patch
new file mode 100644
index 0000000000..82a27c3ac4
--- /dev/null
+++ b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf/libc_memfuncs.patch
@@ -0,0 +1,63 @@
+From 205a3b04e1216c1df199aec95185f7f48b8e0491 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Tue, 6 Oct 2015 09:11:38 +0200
+Subject: Run only pixbuf-lowmem test on GNU libc
+
+The test case depends on GNU libc specific internals so we only run it
+on GNU libc.
+
+This fixes build on Linux with musl libc.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=756078
+---
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Upstream-Status: Backport
+
+ tests/Makefile.am | 5 -----
+ tests/pixbuf-lowmem.c | 8 ++++++++
+ 2 files changed, 8 insertions(+), 5 deletions(-)
+
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index bdd68f3..c122188 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -19,13 +19,8 @@ LDADD = \
+ noinst_PROGRAMS += \
+ pixbuf-read \
+ pixbuf-random \
+- $(NULL)
+-
+-if OS_LINUX
+-noinst_PROGRAMS += \
+ pixbuf-lowmem \
+ $(NULL)
+-endif
+
+ test_programs = \
+ animation \
+diff --git a/tests/pixbuf-lowmem.c b/tests/pixbuf-lowmem.c
+index ae71788..9e9571f 100644
+--- a/tests/pixbuf-lowmem.c
++++ b/tests/pixbuf-lowmem.c
+@@ -24,6 +24,7 @@
+ #include <time.h>
+ #include <string.h>
+
++#ifdef __GLIBC__
+ #define PRETEND_MEM_SIZE (16 * 1024 * 1024)
+ #define REMAINING_MEM_SIZE 100000
+
+@@ -225,3 +226,10 @@ main (int argc, char **argv)
+
+ return 0;
+ }
++#else
++int
++main (int argc, char **argv)
++{
++ return 0;
++}
++#endif
+--
+cgit v0.11.2
+
diff --git a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.32.1.bb b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.32.1.bb
index 084fe3613e..104c743914 100644
--- a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.32.1.bb
+++ b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.32.1.bb
@@ -17,6 +17,7 @@ SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz \
file://extending-libinstall-dependencies.patch \
file://run-ptest \
file://fatal-loader.patch \
+ file://libc_memfuncs.patch \
"
SRC_URI[md5sum] = "b1590189a2e89fab9f871959c168508c"