aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-02 13:50:47 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-04 23:33:12 +0000
commit6d1142b56948c048111c4f78d9909c1846ab225b (patch)
tree25e87cf7378964d07c9b3d36ddf7c04e110bc882
parentd4f49273f21072f910e1960592a900d066d91b1c (diff)
downloadopenembedded-core-6d1142b56948c048111c4f78d9909c1846ab225b.tar.gz
busybox/gtk/perl/base-passwd: Ensure data is correctly expanded
Where variables are used in python, we need to ensure they are expanded. This happens to work at the moment but likely will not happen in future and isn't good code practise. Its mostly an issue around key values, since bitbake has already performed key expansion when these functions are executed. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/base-passwd/base-passwd_3.5.29.bb2
-rw-r--r--meta/recipes-core/busybox/busybox.inc2
-rw-r--r--meta/recipes-devtools/perl/perl_5.22.1.bb2
-rw-r--r--meta/recipes-gnome/gtk+/gtk+3.inc2
-rw-r--r--meta/recipes-gnome/gtk+/gtk+_2.24.29.bb2
5 files changed, 6 insertions, 4 deletions
diff --git a/meta/recipes-core/base-passwd/base-passwd_3.5.29.bb b/meta/recipes-core/base-passwd/base-passwd_3.5.29.bb
index a770168298..10457b2dec 100644
--- a/meta/recipes-core/base-passwd/base-passwd_3.5.29.bb
+++ b/meta/recipes-core/base-passwd/base-passwd_3.5.29.bb
@@ -89,7 +89,7 @@ if [ ! -e $D${sysconfdir}/group ]; then
""" + group + """EOF
fi
"""
- d.setVar('pkg_preinst_${PN}', preinst)
+ d.setVar(d.expand('pkg_preinst_${PN}'), preinst)
}
addtask do_package after do_populate_sysroot
diff --git a/meta/recipes-core/busybox/busybox.inc b/meta/recipes-core/busybox/busybox.inc
index e5710f05f4..f74d1a4565 100644
--- a/meta/recipes-core/busybox/busybox.inc
+++ b/meta/recipes-core/busybox/busybox.inc
@@ -346,6 +346,8 @@ python do_package_prepend () {
dvar = d.getVar('D', True)
pn = d.getVar('PN', True)
def set_alternative_vars(links, target):
+ links = d.expand(links)
+ target = d.expand(target)
f = open('%s%s' % (dvar, links), 'r')
for alt_link_name in f:
alt_link_name = alt_link_name.strip()
diff --git a/meta/recipes-devtools/perl/perl_5.22.1.bb b/meta/recipes-devtools/perl/perl_5.22.1.bb
index 705852c01c..54594b1dfc 100644
--- a/meta/recipes-devtools/perl/perl_5.22.1.bb
+++ b/meta/recipes-devtools/perl/perl_5.22.1.bb
@@ -349,7 +349,7 @@ python populate_packages_prepend () {
# modules. Don't attempt to use the result of do_split_packages() as some
# modules are manually split (eg. perl-module-unicore).
packages = filter(lambda p: 'perl-module-' in p, d.getVar('PACKAGES', True).split())
- d.setVar("RRECOMMENDS_${PN}-modules", ' '.join(packages))
+ d.setVar(d.expand("RRECOMMENDS_${PN}-modules"), ' '.join(packages))
}
PACKAGES_DYNAMIC += "^perl-module-.*"
diff --git a/meta/recipes-gnome/gtk+/gtk+3.inc b/meta/recipes-gnome/gtk+/gtk+3.inc
index 36f7b0c06c..353c521a89 100644
--- a/meta/recipes-gnome/gtk+/gtk+3.inc
+++ b/meta/recipes-gnome/gtk+/gtk+3.inc
@@ -106,6 +106,6 @@ python populate_packages_prepend () {
do_split_packages(d, printmodules_root, '^libprintbackend-(.*)\.so$', 'gtk3-printbackend-%s', 'GTK printbackend module for %s')
if (d.getVar('DEBIAN_NAMES', 1)):
- d.setVar('PKG_${PN}', '${MLPREFIX}libgtk-3.0')
+ d.setVar(d.expand('PKG_${PN}'), '${MLPREFIX}libgtk-3.0')
}
diff --git a/meta/recipes-gnome/gtk+/gtk+_2.24.29.bb b/meta/recipes-gnome/gtk+/gtk+_2.24.29.bb
index 675ef6d80b..cf55d2070a 100644
--- a/meta/recipes-gnome/gtk+/gtk+_2.24.29.bb
+++ b/meta/recipes-gnome/gtk+/gtk+_2.24.29.bb
@@ -30,5 +30,5 @@ python populate_packages_prepend () {
do_split_packages(d, printmodules_root, '^libprintbackend-(.*)\.so$', 'gtk-printbackend-%s', 'GTK printbackend module for %s')
if (d.getVar('DEBIAN_NAMES', True)):
- d.setVar('PKG_${PN}', '${MLPREFIX}libgtk-2.0')
+ d.setVar(d.expand('PKG_${PN}'), '${MLPREFIX}libgtk-2.0')
}