aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJavier Martinez Canillas <javier@dowhile0.org>2012-08-05 21:48:32 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-06 14:18:38 +0100
commita9c73d9d3dd5f7fbee82d7ed3cb88a80aa3cbfbd (patch)
treefb4ad338e42edb53063db53e1b53cf7ea2d246a0
parent84fd332ab2f2c512109fc0a080d03533883fa235 (diff)
downloadopenembedded-core-a9c73d9d3dd5f7fbee82d7ed3cb88a80aa3cbfbd.tar.gz
sudo: use ${bindir} and ${sysconfdir} instead of /usr/bin and /etc
It is considered good practice to use the build system provided variables instead of directly specify hardcoded paths. Signed-off-by: Javier Martinez Canillas <javier@dowhile0.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/sudo/sudo_1.8.5p2.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-extended/sudo/sudo_1.8.5p2.bb b/meta/recipes-extended/sudo/sudo_1.8.5p2.bb
index dfba7e0856..4e4a4436ff 100644
--- a/meta/recipes-extended/sudo/sudo_1.8.5p2.bb
+++ b/meta/recipes-extended/sudo/sudo_1.8.5p2.bb
@@ -1,6 +1,6 @@
require sudo.inc
-PR = "r0"
+PR = "r1"
SRC_URI = "http://ftp.sudo.ws/sudo/dist/sudo-${PV}.tar.gz \
file://libtool.patch \
@@ -24,6 +24,6 @@ do_install_append () {
fi
done
- chmod 4111 ${D}/usr/bin/sudo
- chmod 0440 ${D}/etc/sudoers
+ chmod 4111 ${D}${bindir}/sudo
+ chmod 0440 ${D}${sysconfdir}/sudoers
}