aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2013-02-08 14:52:19 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-14 23:16:53 +0000
commita9b42c8e85332a65788b1434f926186d4887b287 (patch)
treeb822a603ed465567f561b845772eae488ad995ac
parent6f3ace8ba75eed891aa4844a6830bedca3d8b70e (diff)
downloadopenembedded-core-a9b42c8e85332a65788b1434f926186d4887b287.tar.gz
tzdata: We shouldn't override the localtime if it is valid
The code where mistakenly replacing the localtime file setting so we end with a copy of file instead of a symbolic link. This fixes it so now, we'll only do that in case the link is pointing to invalid data. Change-Id: I16dfa5ea4f293c48bb396f4e23a2ea53e6c9e745 Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/tzdata/tzdata_2012d.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-extended/tzdata/tzdata_2012d.bb b/meta/recipes-extended/tzdata/tzdata_2012d.bb
index 974110172f..9ec6715bc3 100644
--- a/meta/recipes-extended/tzdata/tzdata_2012d.bb
+++ b/meta/recipes-extended/tzdata/tzdata_2012d.bb
@@ -5,7 +5,7 @@ LICENSE = "PD"
LIC_FILES_CHKSUM = "file://asia;beginline=2;endline=3;md5=06468c0e84ef4d4c97045a4a29b08234"
DEPENDS = "tzcode-native"
-PR = "r2"
+PR = "r3"
inherit allarch
@@ -93,12 +93,12 @@ pkg_postinst_${PN} () {
echo "You have an invalid TIMEZONE setting in ${src}"
echo "Your ${etc_lt} has been reset to Universal; enjoy!"
tz="Universal"
+ echo "Updating ${etc_lt} with $D${datadir}/zoneinfo/${tz}"
+ if [ -L ${etc_lt} ] ; then
+ rm -f "${etc_lt}"
+ fi
+ cp -f "$D${datadir}/zoneinfo/${tz}" "${etc_lt}"
fi
- echo "Updating ${etc_lt} with $D${datadir}/zoneinfo/${tz}"
- if [ -L ${etc_lt} ] ; then
- rm -f "${etc_lt}"
- fi
- cp -f "$D${datadir}/zoneinfo/${tz}" "${etc_lt}"
}
# Packages primarily organized by directory with a major city