aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-07-18 09:02:18 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-21 10:46:31 +0100
commit682a213dc732074985bf86f508305fc6eafe18d9 (patch)
tree909de89eb6f3f60203c3b3a68a5530d515f3fed3
parent48c1e10f53894e666283aac086e61444d2c1ed69 (diff)
downloadopenembedded-core-682a213dc732074985bf86f508305fc6eafe18d9.tar.gz
cpan.bbclass: Perform more mangling for perl path
On hosts where we may already be past the #! limit this is required and this is safe on the target as well. This is be7fe31 in oe.dev. Related to this we now bump all PRs for recipes that inherit cpan. Note that in oe.dev we mangle for perl but here we use the new nativeperl script. Signed-off-by: Tom Rini <tom_rini@mentor.com>
-rw-r--r--meta/classes/cpan.bbclass3
-rw-r--r--meta/recipes-devtools/perl/liburi-perl_1.58.bb2
-rw-r--r--meta/recipes-devtools/perl/libxml-parser-perl_2.40.bb2
-rw-r--r--meta/recipes-devtools/perl/libxml-perl_0.08.bb2
-rw-r--r--meta/recipes-devtools/perl/libxml-simple-perl_2.18.bb2
-rw-r--r--meta/recipes-devtools/sgmlspl/sgmlspl-native_1.03ii.bb2
-rw-r--r--meta/recipes-extended/perl/libconvert-asn1-perl_0.22.bb2
-rw-r--r--meta/recipes-extended/perl/libtimedate-perl_1.20.bb2
-rw-r--r--meta/recipes-extended/perl/libxml-namespacesupport-perl_1.11.bb2
-rw-r--r--meta/recipes-extended/perl/libxml-sax-perl_0.96.bb2
10 files changed, 12 insertions, 9 deletions
diff --git a/meta/classes/cpan.bbclass b/meta/classes/cpan.bbclass
index cbf428d3a2..cb1c2f40c7 100644
--- a/meta/classes/cpan.bbclass
+++ b/meta/classes/cpan.bbclass
@@ -35,6 +35,9 @@ cpan_do_compile () {
cpan_do_install () {
oe_runmake DESTDIR="${D}" install_vendor
+ for PERLSCRIPT in `grep -rIEl '#!${bindir}/perl-native.*/perl' ${D}`; do
+ sed -i -e 's|^#!${bindir}/perl-native.*/perl|#!/usr/bin/env nativeperl|' $PERLSCRIPT
+ done
}
EXPORT_FUNCTIONS do_configure do_compile do_install
diff --git a/meta/recipes-devtools/perl/liburi-perl_1.58.bb b/meta/recipes-devtools/perl/liburi-perl_1.58.bb
index 76a1231388..ebb4911d4f 100644
--- a/meta/recipes-devtools/perl/liburi-perl_1.58.bb
+++ b/meta/recipes-devtools/perl/liburi-perl_1.58.bb
@@ -4,7 +4,7 @@ and manipulate the various components that make up these strings."
SECTION = "libs"
LICENSE = "Artistic | GPLv1+"
-PR = "r0"
+PR = "r1"
LIC_FILES_CHKSUM = "file://README;beginline=26;endline=30;md5=6c33ae5c87fd1c4897714e122dd9c23d"
diff --git a/meta/recipes-devtools/perl/libxml-parser-perl_2.40.bb b/meta/recipes-devtools/perl/libxml-parser-perl_2.40.bb
index 3f1a0ad500..1d1593b171 100644
--- a/meta/recipes-devtools/perl/libxml-parser-perl_2.40.bb
+++ b/meta/recipes-devtools/perl/libxml-parser-perl_2.40.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://README;beginline=2;endline=6;md5=c8767d7516229f07b26e
DEPENDS += "expat expat-native"
-PR = "r3"
+PR = "r4"
SRC_URI = "http://www.cpan.org/modules/by-module/XML/XML-Parser-${PV}.tar.gz"
SRC_URI[md5sum] = "c66e9adba003d0667cc40115ccd837a5"
diff --git a/meta/recipes-devtools/perl/libxml-perl_0.08.bb b/meta/recipes-devtools/perl/libxml-perl_0.08.bb
index 9c74cdb6b3..fb637a8487 100644
--- a/meta/recipes-devtools/perl/libxml-perl_0.08.bb
+++ b/meta/recipes-devtools/perl/libxml-perl_0.08.bb
@@ -5,7 +5,7 @@ XML::Grove and others."
SUMMARY = "Collection of Perl modules for working with XML."
SECTION = "libs"
LICENSE = "Artistic | GPLv1+"
-PR = "r0"
+PR = "r1"
LIC_FILES_CHKSUM = "file://README;beginline=33;endline=35;md5=1705549eef7577a3d6ba71123a1f0ce8"
diff --git a/meta/recipes-devtools/perl/libxml-simple-perl_2.18.bb b/meta/recipes-devtools/perl/libxml-simple-perl_2.18.bb
index 89b65b29da..3a50d7f1d2 100644
--- a/meta/recipes-devtools/perl/libxml-simple-perl_2.18.bb
+++ b/meta/recipes-devtools/perl/libxml-simple-perl_2.18.bb
@@ -2,7 +2,7 @@ SECTION = "libs"
LICENSE = "Artistic"
LIC_FILES_CHKSUM = "file://README;beginline=70;md5=94aa5d46682b411a53a5494cfb22640e"
DEPENDS += "libxml-parser-perl"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://www.cpan.org/modules/by-module/XML/XML-Simple-${PV}.tar.gz"
diff --git a/meta/recipes-devtools/sgmlspl/sgmlspl-native_1.03ii.bb b/meta/recipes-devtools/sgmlspl/sgmlspl-native_1.03ii.bb
index 4e01f17b3e..28e0e9f391 100644
--- a/meta/recipes-devtools/sgmlspl/sgmlspl-native_1.03ii.bb
+++ b/meta/recipes-devtools/sgmlspl/sgmlspl-native_1.03ii.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "http://search.cpan.org/src/DMEGG/SGMLSpm-1.03ii/DOC/HTML/SGMLSpm/sgm
SECTION = "libs"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://www.cpan.org/authors/id/D/DM/DMEGG/SGMLSpm-${PV}.tar.gz \
file://combined.patch"
diff --git a/meta/recipes-extended/perl/libconvert-asn1-perl_0.22.bb b/meta/recipes-extended/perl/libconvert-asn1-perl_0.22.bb
index fc77b75090..48e107c8fa 100644
--- a/meta/recipes-extended/perl/libconvert-asn1-perl_0.22.bb
+++ b/meta/recipes-extended/perl/libconvert-asn1-perl_0.22.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Convert::ASN1 - ASN.1 Encode/Decode library"
SECTION = "libs"
LICENSE = "Artistic|GPLv1+"
LIC_FILES_CHKSUM = "file://README;beginline=10;endline=12;md5=a64b291b13ffddeef33b14f047ee8b26"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GB/GBARR/Convert-ASN1-${PV}.tar.gz"
diff --git a/meta/recipes-extended/perl/libtimedate-perl_1.20.bb b/meta/recipes-extended/perl/libtimedate-perl_1.20.bb
index 7298f37fd1..c925980d37 100644
--- a/meta/recipes-extended/perl/libtimedate-perl_1.20.bb
+++ b/meta/recipes-extended/perl/libtimedate-perl_1.20.bb
@@ -3,7 +3,7 @@ SECTION = "libs"
# You can redistribute it and/or modify it under the same terms as Perl itself.
LICENSE = "Artistic|GPLv1+"
LIC_FILES_CHKSUM = "file://README;beginline=21;md5=576b7cb41e5e821501a01ed66f0f9d9e"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GB/GBARR/TimeDate-${PV}.tar.gz"
diff --git a/meta/recipes-extended/perl/libxml-namespacesupport-perl_1.11.bb b/meta/recipes-extended/perl/libxml-namespacesupport-perl_1.11.bb
index d96430e616..f306ff1996 100644
--- a/meta/recipes-extended/perl/libxml-namespacesupport-perl_1.11.bb
+++ b/meta/recipes-extended/perl/libxml-namespacesupport-perl_1.11.bb
@@ -5,7 +5,7 @@ DESCRIPTION = "XML::NamespaceSupport offers a simple way to process namespace-ba
SECTION = "libs"
LICENSE = "Artistic|GPLv1+"
-PR = "r0"
+PR = "r1"
LIC_FILES_CHKSUM = "file://META.yml;beginline=22;endline=22;md5=3b2b564dae8b9af9e8896e85c07dcbe5"
diff --git a/meta/recipes-extended/perl/libxml-sax-perl_0.96.bb b/meta/recipes-extended/perl/libxml-sax-perl_0.96.bb
index 13956cb16e..97d2025a37 100644
--- a/meta/recipes-extended/perl/libxml-sax-perl_0.96.bb
+++ b/meta/recipes-extended/perl/libxml-sax-perl_0.96.bb
@@ -11,7 +11,7 @@ SECTION = "libs"
LICENSE = "Artistic|GPLv1+"
DEPENDS += "libxml-namespacesupport-perl-native"
RDEPENDS_${PN} += "libxml-namespacesupport-perl perl-module-file-temp"
-PR = "r0"
+PR = "r1"
LIC_FILES_CHKSUM = "file://LICENSE;md5=65c4cd8f39c24c7135ed70dacbcb09e3"