summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-08 16:46:50 +0000
committerSteve Sakoman <steve@sakoman.com>2021-03-11 05:00:02 -1000
commitb5bcbe1835ad95a65c2c01212a35f9388ac0dffc (patch)
treee3d2152c102270066d4d126b06a1d161ba5fdea9
parentd4df6cfe5b8d81c53bf5fc2a3b97886739f36a71 (diff)
downloadopenembedded-core-b5bcbe1835ad95a65c2c01212a35f9388ac0dffc.tar.gz
build-appliance-image: Drop kernel module handling
kernel-devsrc is a dependency of the image so we no longer need the symlink creation code or the module-base inherit/dependency as it is included in that recipe. The KERNEL_VERSION usage was broken anyway as the module usage would have needed a: do_image[depends] += "build-appliance-image:do_configure" which wasn't present so it was indeterminate if KERNEL_VERSION was set correctly. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit a46b43bb67b2f87ec370480e50a2e2d111555b75) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-core/images/build-appliance-image_15.0.0.bb8
1 files changed, 1 insertions, 7 deletions
diff --git a/meta/recipes-core/images/build-appliance-image_15.0.0.bb b/meta/recipes-core/images/build-appliance-image_15.0.0.bb
index f5cc20fa6d..086e20023f 100644
--- a/meta/recipes-core/images/build-appliance-image_15.0.0.bb
+++ b/meta/recipes-core/images/build-appliance-image_15.0.0.bb
@@ -22,7 +22,7 @@ APPEND += "rootfstype=ext4 quiet"
DEPENDS = "zip-native python3-pip-native"
IMAGE_FSTYPES = "wic.vmdk"
-inherit core-image module-base setuptools3
+inherit core-image setuptools3
SRCREV ?= "fadf7d3343305337c38a5243797723c68e88276a"
SRC_URI = "git://git.yoctoproject.org/poky;branch=dunfell \
@@ -61,12 +61,6 @@ fakeroot do_populate_poky_src () {
# Place the README_VirtualBox_Toaster file in builders home folder.
cp ${WORKDIR}/README_VirtualBox_Toaster.txt ${IMAGE_ROOTFS}/home/builder/
- # Create a symlink, needed for out-of-tree kernel modules build
- if [ ! -e ${IMAGE_ROOTFS}/lib/modules/${KERNEL_VERSION}/build ]; then
- rm -f ${IMAGE_ROOTFS}/lib/modules/${KERNEL_VERSION}/build
- lnr ${IMAGE_ROOTFS}${KERNEL_SRC_PATH} ${IMAGE_ROOTFS}/lib/modules/${KERNEL_VERSION}/build
- fi
-
echo "INHERIT += \"rm_work\"" >> ${IMAGE_ROOTFS}/home/builder/poky/build/conf/auto.conf
echo "export LC_ALL=en_US.utf8" >> ${IMAGE_ROOTFS}/home/builder/.bashrc