summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Baryshkov <dmitry.baryshkov@linaro.org>2020-12-11 17:28:18 +0300
committerSteve Sakoman <steve@sakoman.com>2021-01-04 04:50:23 -1000
commit92cd97616f68dfd2fea2ad039c892d3faf1a0f32 (patch)
tree9b0ab2402b8ab4b57e1a75edb3ddc912aa568d28
parent1625481cdfc6560bc8e49aea7f7e9175cbaaa15e (diff)
downloadopenembedded-core-92cd97616f68dfd2fea2ad039c892d3faf1a0f32.tar.gz
perl: fix installation failure because of shell issue
On one of my buildservers I noticed perl do_install failing with the following message: | rm: cannot remove '<OEROOT>/tmp-rpb-glibc/work/armv8-2a-linaro-linux/perl/5.32.0-r0/image//usr/lib/perl5/5.32.0/*/CORE/libperl.so': No such file or directory I tracked this down to shell being dash rather than bash not being able to expand this glob in the middle of the filename. So replace the glob expansion with the simpler one which works in all cases. Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov@linaro.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit d1ea1b5c12120abdd085dc4eb69120af9258a99b) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-devtools/perl/perl_5.30.1.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.30.1.bb b/meta/recipes-devtools/perl/perl_5.30.1.bb
index b53aff1216..ee6eb6ef0f 100644
--- a/meta/recipes-devtools/perl/perl_5.30.1.bb
+++ b/meta/recipes-devtools/perl/perl_5.30.1.bb
@@ -146,8 +146,9 @@ do_install() {
install lib/ExtUtils/typemap ${D}${libdir}/perl5/${PV}/ExtUtils/
# Fix up shared library
- rm ${D}/${libdir}/perl5/${PV}/*/CORE/libperl.so
- ln -sf ../../../../libperl.so.${PERL_LIB_VER} $(echo ${D}/${libdir}/perl5/${PV}/*/CORE)/libperl.so
+ dir=$(echo ${D}/${libdir}/perl5/${PV}/*/CORE)
+ rm $dir/libperl.so
+ ln -sf ../../../../libperl.so.${PERL_LIB_VER} $dir/libperl.so
}
do_install_append_class-target() {