summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2020-12-08 00:03:57 -0800
committerSteve Sakoman <steve@sakoman.com>2021-01-04 04:50:23 -1000
commit1625481cdfc6560bc8e49aea7f7e9175cbaaa15e (patch)
tree66cf6fa4c3e2bb6b21c922968de086d7134e21bd
parent7b84c9ea009b5452a21233483516de5e070fbe82 (diff)
downloadopenembedded-core-1625481cdfc6560bc8e49aea7f7e9175cbaaa15e.tar.gz
archiver.bbclass: Fix --runall=deploy_archives for images
Fixed: INHERIT += "archiver" COPYLEFT_LICENSE_INCLUDE = "*" $ bitbake core-image-minimal --runall=deploy_archives [snip] KeyError: '/path/to/meta/recipes-core/images/core-image-minimal.bb:do_ar_original' [snip] Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 59785a51110c450c7629218f6042f1d9d309618e) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/classes/archiver.bbclass1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/classes/archiver.bbclass b/meta/classes/archiver.bbclass
index 1a3c190604..990f1d4674 100644
--- a/meta/classes/archiver.bbclass
+++ b/meta/classes/archiver.bbclass
@@ -591,6 +591,7 @@ addtask do_dumpdata
addtask do_ar_recipe
addtask do_deploy_archives
do_build[recrdeptask] += "do_deploy_archives"
+do_rootfs[recrdeptask] += "do_deploy_archives"
do_populate_sdk[recrdeptask] += "do_deploy_archives"
python () {