aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorValentin Popa <valentin.popa@intel.com>2014-04-14 17:51:25 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-19 10:24:36 +0100
commit97bc1bce9a226cc02db8a5afc2c0d4f4f70034a6 (patch)
tree4cec3ef8ca76342b1ffd5d77012a48ba335cd641
parent813fa9ed5e492e5dc08155d23d74127ca87304df (diff)
downloadopenembedded-core-97bc1bce9a226cc02db8a5afc2c0d4f4f70034a6.tar.gz
mesa: double check for eglplatform.h
Even if 'egl' is in PACKAGECONFIG, mesa egl support can be disabled explicitly (changing configure flags using a .bbappend, for example). On dora, meta-fsl-arm is an example of this kind. On master there are no known cases, and we should encourge package configuration through PACKAGECONFIG. This patch adds another check for the existence of eglplatform.h before 'sed' can alter it. Signed-off-by: Valentin Popa <valentin.popa@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/mesa/mesa_9.1.6.bb4
-rw-r--r--meta/recipes-graphics/mesa/mesa_git.bb4
2 files changed, 6 insertions, 2 deletions
diff --git a/meta/recipes-graphics/mesa/mesa_9.1.6.bb b/meta/recipes-graphics/mesa/mesa_9.1.6.bb
index 6e9cd826f0..388cfd785c 100644
--- a/meta/recipes-graphics/mesa/mesa_9.1.6.bb
+++ b/meta/recipes-graphics/mesa/mesa_9.1.6.bb
@@ -19,6 +19,8 @@ S = "${WORKDIR}/Mesa-${PV}"
#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
do_install_append() {
if ${@base_contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
- sed -i -e 's/^#ifdef MESA_EGL_NO_X11_HEADERS/#if ${@base_contains('DISTRO_FEATURES', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
+ if [ -e "${D}${includedir}/EGL/eglplatform.h" ]; then
+ sed -i -e 's/^#ifdef MESA_EGL_NO_X11_HEADERS/#if ${@base_contains('DISTRO_FEATURES', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
+ fi
fi
} \ No newline at end of file
diff --git a/meta/recipes-graphics/mesa/mesa_git.bb b/meta/recipes-graphics/mesa/mesa_git.bb
index 1babcc05a9..714911f81f 100644
--- a/meta/recipes-graphics/mesa/mesa_git.bb
+++ b/meta/recipes-graphics/mesa/mesa_git.bb
@@ -23,6 +23,8 @@ S = "${WORKDIR}/git"
#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
do_install_append() {
if ${@base_contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
- sed -i -e 's/^#ifdef MESA_EGL_NO_X11_HEADERS/#if ${@base_contains('DISTRO_FEATURES', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
+ if [ -e "${D}${includedir}/EGL/eglplatform.h" ]; then
+ sed -i -e 's/^#ifdef MESA_EGL_NO_X11_HEADERS/#if ${@base_contains('DISTRO_FEATURES', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
+ fi
fi
}