aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-04-23 20:35:25 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-26 09:08:46 +0100
commit4954cd6abad556d75beec860e82750bb1090a109 (patch)
tree8022ed5dc5d2c9394b44fbad3b34fd8c2f9e123d
parent447dba2a6a077c83083556ab79ab265d4b8a048f (diff)
downloadopenembedded-core-4954cd6abad556d75beec860e82750bb1090a109.tar.gz
subversion: Add -P to CPPFLAGS
see https://gcc.gnu.org/gcc-5/porting_to.html we need to stop the preprocessor from generating the #line directives or we run into issues like | checking for apr_int64_t Python/C API format string... | configure: error: failed to recognize APR_INT64_T_FMT on this platform | Configure failed. The contents of all config.log files follows to aid debugging | ERROR: oe_runconf failed Rightly subversion should be fixed but lets leave that to subversion folks Change-Id: I02a89798ff949f79967ab0a73adcddaa4218662d (From OE-Core rev: 7793b1c425077ed6ed11a9bc2a8b1b96612b1c96) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/subversion/subversion_1.8.9.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/subversion/subversion_1.8.9.bb b/meta/recipes-devtools/subversion/subversion_1.8.9.bb
index 1ef59a0c00..0e8b122bfa 100644
--- a/meta/recipes-devtools/subversion/subversion_1.8.9.bb
+++ b/meta/recipes-devtools/subversion/subversion_1.8.9.bb
@@ -7,7 +7,7 @@ HOMEPAGE = "http://subversion.tigris.org"
BBCLASSEXTEND = "native"
-inherit gettext
+inherit gettext pythonnative
SRC_URI = "${APACHE_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
file://libtool2.patch \
@@ -33,6 +33,7 @@ EXTRA_OECONF = " \
inherit autotools
export LDFLAGS += " -L${STAGING_LIBDIR} "
+CPPFLAGS += "-P"
acpaths = "-I build/ -I build/ac-macros/"