aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2015-04-28 15:46:04 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-29 17:53:06 +0100
commit2e67a2d35ffcaa0d35363b05209060aff7026c9a (patch)
tree437e37fdba9760c5133ea9d7844885c2571a4a91
parentfc732ee788a254ec388cff8fe5619348014255d3 (diff)
downloadopenembedded-core-2e67a2d35ffcaa0d35363b05209060aff7026c9a.tar.gz
busybox: unbreak tar of uncompressed files
A patch was added to fix compressed tar files, but broke uncompressed tar files, this fix is from the busybox mailing list http://lists.busybox.net/pipermail/busybox/2014-January/080389.html [YOCTO #7645] Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/busybox/busybox/unbreak_noncompressed_tar.patch23
-rw-r--r--meta/recipes-core/busybox/busybox_1.22.1.bb1
2 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-core/busybox/busybox/unbreak_noncompressed_tar.patch b/meta/recipes-core/busybox/busybox/unbreak_noncompressed_tar.patch
new file mode 100644
index 0000000000..3c3c23a54a
--- /dev/null
+++ b/meta/recipes-core/busybox/busybox/unbreak_noncompressed_tar.patch
@@ -0,0 +1,23 @@
+
+This patch allows tar to continue correctly when it does not detect
+a compressed format. This allows tar to then untar a non-compressed
+tar file.
+
+See this thread for details: http://lists.busybox.net/pipermail/busybox/2014-January/080389.html
+
+Upstream-Status: Inappropriate [Upstream has different fix with additional functionality]
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+
+Index: busybox-1.22.1/archival/libarchive/open_transformer.c
+===================================================================
+--- busybox-1.22.1.orig/archival/libarchive/open_transformer.c
++++ busybox-1.22.1/archival/libarchive/open_transformer.c
+@@ -200,7 +200,7 @@ int FAST_FUNC open_zipped(const char *fn
+ || (ENABLE_FEATURE_SEAMLESS_BZ2)
+ || (ENABLE_FEATURE_SEAMLESS_XZ)
+ ) {
+- setup_unzip_on_fd(fd, /*fail_if_not_detected:*/ 1);
++ setup_unzip_on_fd(fd, /*fail_if_not_detected:*/ 0);
+ }
+
+ return fd;
diff --git a/meta/recipes-core/busybox/busybox_1.22.1.bb b/meta/recipes-core/busybox/busybox_1.22.1.bb
index ae8eca70ff..1b1eaf35ac 100644
--- a/meta/recipes-core/busybox/busybox_1.22.1.bb
+++ b/meta/recipes-core/busybox/busybox_1.22.1.bb
@@ -35,6 +35,7 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
file://CVE-2014-9645_busybox_reject_module_names_with_slashes.patch \
file://lzop-add-overflow-check.patch \
file://libarchive-open_zipped-does-not-need-to-check-extens.patch \
+ file://unbreak_noncompressed_tar.patch \
"
SRC_URI[tarball.md5sum] = "337d1a15ab1cb1d4ed423168b1eb7d7e"