aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew McClintock <msm@freescale.com>2012-09-11 12:56:53 -0500
committerScott Garman <scott.a.garman@intel.com>2012-09-24 09:51:12 -0700
commit2136030c1d240d9b8f123e3c8af5dacf66e86ab4 (patch)
tree149b362507ea59a8873d91011069cafba3f2832f
parent961498e3b4c4a93070bf278e67fc48c02333cd63 (diff)
downloadopenembedded-core-2136030c1d240d9b8f123e3c8af5dacf66e86ab4.tar.gz
sysvinit-inittab_2.88dsf.bb: only run serial checks at boot if we have items to check
Right now, we delay running the serial console checks to we boot up. This causes issues for read only file systems. So, if have not configured any serial ports to check via SERIAL_CONSOLES_CHECK we can skip the check at boot. This fixes any issues with read only file systems and ipk packaging. Signed-off-by: Matthew McClintock <msm@freescale.com>
-rw-r--r--meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb b/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb
index 1089edbcb4..5b79caffc2 100644
--- a/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb
+++ b/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Inittab for sysvinit"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-PR = "r7"
+PR = "r8"
SRC_URI = "file://inittab"
@@ -54,7 +54,7 @@ EOF
pkg_postinst_${PN} () {
# run this on the target
-if [ "x$D" == "x" ]; then
+if [ "x$D" = "x" ]; then
tmp="${SERIAL_CONSOLES_CHECK}"
for i in $tmp
do
@@ -65,7 +65,11 @@ if [ "x$D" == "x" ]; then
done
kill -HUP 1
else
- exit 1
+ if [ "${SERIAL_CONSOLES_CHECK}" = "" ]; then
+ exit 0
+ else
+ exit 1
+ fi
fi
}