aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew McClintock <msm@freescale.com>2012-08-21 13:38:11 -0500
committerScott Garman <scott.a.garman@intel.com>2012-09-24 09:51:09 -0700
commit0fd7b7dd361e59c687366480cd9f89c81c2e5bce (patch)
tree492e53c308f36c3d802e0d5914a2348723c92ada
parentfc513eda1cfccc583f49847c3c04b5c781585e15 (diff)
downloadopenembedded-core-0fd7b7dd361e59c687366480cd9f89c81c2e5bce.tar.gz
distutils.bblass: change order of args to install step
This let's the user override install-lib argument again if it needs to be something else, otherwise things like python-setuptools won't be able to modify the install-lib dir This fixes a new issue exposed by my previous distutils patch that fixed the python modules default install location Signed-off-by: Matthew McClintock <msm@freescale.com>
-rw-r--r--meta/classes/distutils.bbclass2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/classes/distutils.bbclass b/meta/classes/distutils.bbclass
index 67ad5b3416..ec471babd7 100644
--- a/meta/classes/distutils.bbclass
+++ b/meta/classes/distutils.bbclass
@@ -38,7 +38,7 @@ distutils_do_install() {
STAGING_LIBDIR=${STAGING_LIBDIR} \
PYTHONPATH=${D}/${PYTHON_SITEPACKAGES_DIR} \
BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
- ${STAGING_BINDIR_NATIVE}/python setup.py install ${DISTUTILS_INSTALL_ARGS} --install-lib=${D}${libdir}/${PYTHON_DIR} || \
+ ${STAGING_BINDIR_NATIVE}/python setup.py install --install-lib=${D}${libdir}/${PYTHON_DIR} ${DISTUTILS_INSTALL_ARGS}|| \
bbfatal "python setup.py install execution failed."
for i in `find ${D} -name "*.py"` ; do \