aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoryanjun.zhu <yanjun.zhu@windriver.com>2012-11-30 19:23:48 +0800
committerRoss Burton <ross.burton@intel.com>2013-02-19 11:31:55 +0000
commit11544f573bc94ce69a8a76d645e46ab6359dee78 (patch)
tree447eaebc6a4fbf1ce2d099f7348b5373a5d59d66
parent00d0e1ac741e5fc01a40feb7dcc7ecd3906b5ce4 (diff)
downloadopenembedded-core-11544f573bc94ce69a8a76d645e46ab6359dee78.tar.gz
Python: Fix for CVE-2012-2135
Reference:http://http://bugs.python.org/issue14579 The utf-16 decoder in Python 3.1 through 3.3 does not update the aligned_end variable after calling the unicode_decode_call_errorhandler function, which allows remote attackers to obtain sensitive information (process memory) or cause a denial of service (memory corruption and crash) via unspecified vectors. http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2012-2135 [YOCTO #3450] Signed-off-by: yanjun.zhu <yanjun.zhu@windriver.com>
-rw-r--r--meta/recipes-devtools/python/python/python-2.7.3-CVE-2012-2135.patch24
-rw-r--r--meta/recipes-devtools/python/python_2.7.3.bb3
2 files changed, 26 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python/python-2.7.3-CVE-2012-2135.patch b/meta/recipes-devtools/python/python/python-2.7.3-CVE-2012-2135.patch
new file mode 100644
index 0000000000..ad118b04d9
--- /dev/null
+++ b/meta/recipes-devtools/python/python/python-2.7.3-CVE-2012-2135.patch
@@ -0,0 +1,24 @@
+Upstream-Status: Backport
+
+Reference:http://bugs.python.org/issue14579
+
+The utf-16 decoder in Python 3.1 through 3.3 does not update the
+aligned_end variable after calling the unicode_decode_call_errorhandler
+function, which allows remote attackers to obtain sensitive information
+(process memory) or cause a denial of service (memory corruption and crash)
+via unspecified vectors.
+
+http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2012-2135
+Signed-off-by: yanjun.zhu <yanjun.zhu@windriver.com>
+diff -urpN a/Objects/unicodeobject.c b/Objects/unicodeobject.c
+--- a/Objects/unicodeobject.c 2012-11-12 16:25:33.000000000 +0800
++++ b/Objects/unicodeobject.c 2012-11-12 16:26:22.000000000 +0800
+@@ -2568,7 +2568,7 @@ PyUnicode_DecodeUTF16Stateful(const char
+ }
+
+ /* UTF-16 code pair: */
+- if (q >= e) {
++ if (e - q < 2) {
+ errmsg = "unexpected end of data";
+ startinpos = (((const char *)q)-2)-starts;
+ endinpos = ((const char *)e)-starts;
diff --git a/meta/recipes-devtools/python/python_2.7.3.bb b/meta/recipes-devtools/python/python_2.7.3.bb
index 3eb36fc9aa..1968629f11 100644
--- a/meta/recipes-devtools/python/python_2.7.3.bb
+++ b/meta/recipes-devtools/python/python_2.7.3.bb
@@ -1,6 +1,6 @@
require python.inc
DEPENDS = "python-native bzip2 db gdbm openssl readline sqlite3 zlib"
-PR = "${INC_PR}.2"
+PR = "${INC_PR}.3"
DISTRO_SRC_URI ?= "file://sitecustomize.py"
DISTRO_SRC_URI_linuxstdbase = ""
@@ -27,6 +27,7 @@ SRC_URI += "\
file://avoid_warning_for_sunos_specific_module.patch \
file://python-2.7.3-berkeley-db-5.3.patch \
file://python-2.7.3-remove-bsdb-rpath.patch \
+ file://python-2.7.3-CVE-2012-2135.patch \
"
S = "${WORKDIR}/Python-${PV}"