aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-07-26 00:36:48 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-27 14:07:22 +0100
commitd2dba9aebef323a57824b41d09991850c703be35 (patch)
tree7028f630a300cb7a23ab63bbe55c55a59549b822
parent21a57b98ff5091a5563c00093081297a6c586208 (diff)
downloadopenembedded-core-d2dba9aebef323a57824b41d09991850c703be35.tar.gz
pkgconfig: Fix packaging issue
The pkg.m4 file should be packaged as part of the base package instead of the -dev package, it had been in the base package, but I seemed to have missed that it moved during my PACKAGES reorder, and this caused the meta-toolchain to break [YOCTO #1908] Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-devtools/pkgconfig/pkgconfig.inc5
-rw-r--r--meta/recipes-devtools/pkgconfig/pkgconfig_0.25.bb2
2 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-devtools/pkgconfig/pkgconfig.inc b/meta/recipes-devtools/pkgconfig/pkgconfig.inc
index 00c23d7ff8..10dba04896 100644
--- a/meta/recipes-devtools/pkgconfig/pkgconfig.inc
+++ b/meta/recipes-devtools/pkgconfig/pkgconfig.inc
@@ -32,4 +32,9 @@ do_configure_prepend () {
BBCLASSEXTEND = "native nativesdk"
+# Set an empty dev package to ensure the base PN package gets
+# the pkg.m4 macros, pkgconfig does not deliver any other -dev
+# files.
+FILES_${PN}-dev = ""
FILES_${PN} += "${datadir}/aclocal/pkg.m4"
+RREPLACES_${PN}-dev = "${PN}"
diff --git a/meta/recipes-devtools/pkgconfig/pkgconfig_0.25.bb b/meta/recipes-devtools/pkgconfig/pkgconfig_0.25.bb
index 1d7ba49b95..08a3dbfc29 100644
--- a/meta/recipes-devtools/pkgconfig/pkgconfig_0.25.bb
+++ b/meta/recipes-devtools/pkgconfig/pkgconfig_0.25.bb
@@ -1,6 +1,6 @@
require pkgconfig.inc
-PR = "r3"
+PR = "r4"
SRC_URI[md5sum] = "a3270bab3f4b69b7dc6dbdacbcae9745"
SRC_URI[sha256sum] = "3ba691ee2431f32ccb8efa131e59bf23e37f122dc66791309023ca6dcefcd10e"