aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-18 17:38:05 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-18 22:17:44 +0100
commitcf63d9068c3a8c635dfc240d30dfff278be9b0e2 (patch)
treecfc9d719c77ef4182eea224f2d692c56d732bba1
parent7d49af3a811472a2a47453bef0813b89c6331ae7 (diff)
downloadopenembedded-core-cf63d9068c3a8c635dfc240d30dfff278be9b0e2.tar.gz
bitbake.conf: Define USRBINPATH globally instead of individually
Many recipes are now having to define PERLPATH and PYTHONPATH variables. Creating USRBINPATH in bitbake.conf means we can remove all these lines from the many recipes now needing this and simplify the code changes needed in each case, reducing the chance of errors being introduced. Also fixup glib python binary location issue and fix function indentation. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/conf/bitbake.conf4
-rw-r--r--meta/recipes-core/eglibc/eglibc-package.inc5
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0_2.32.4.bb17
-rw-r--r--meta/recipes-core/glib-2.0/glib.inc1
-rw-r--r--meta/recipes-devtools/autoconf/autoconf.inc8
-rw-r--r--meta/recipes-devtools/automake/automake_1.12.1.bb8
-rw-r--r--meta/recipes-devtools/quilt/quilt_0.60.bb5
-rw-r--r--meta/recipes-extended/groff/groff_1.20.1.bb8
8 files changed, 19 insertions, 37 deletions
diff --git a/meta/conf/bitbake.conf b/meta/conf/bitbake.conf
index c94012e665..1525e44b2c 100644
--- a/meta/conf/bitbake.conf
+++ b/meta/conf/bitbake.conf
@@ -66,6 +66,10 @@ localstatedir_nativesdk = "/var"
# := is used carefully here
#
target_datadir := "${datadir}"
+# Used to find env/perl/python
+USRBINPATH = "${bindir}"
+USRBINPATH_class-native = "/usr/bin"
+USRBINPATH_class-nativesdk = "/usr/bin"
##################################################################
# Architecture-dependent build variables.
diff --git a/meta/recipes-core/eglibc/eglibc-package.inc b/meta/recipes-core/eglibc/eglibc-package.inc
index 9a7febe666..119b443649 100644
--- a/meta/recipes-core/eglibc/eglibc-package.inc
+++ b/meta/recipes-core/eglibc/eglibc-package.inc
@@ -77,9 +77,6 @@ DESCRIPTION_libsotruss = "Library to support sotruss which traces calls through
inherit libc-common multilib_header
-PERLPATH = "${bindir}/env perl"
-PERLPATH_virtclass-nativesdk = "/usr/bin/env perl"
-
do_install_append () {
rm -f ${D}${sysconfdir}/localtime
rm -rf ${D}${localstatedir}
@@ -87,7 +84,7 @@ do_install_append () {
oe_multilib_header bits/syscall.h
if [ -f ${D}${bindir}/mtrace ]; then
- sed -i -e '1s,#!.*perl,#! ${PERLPATH},' -e '2s,exec.*perl,exec ${PERLPATH},' ${D}${bindir}/mtrace
+ sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' -e '2s,exec.*perl,exec ${USRBINPATH}/env perl,' ${D}${bindir}/mtrace
fi
}
diff --git a/meta/recipes-core/glib-2.0/glib-2.0_2.32.4.bb b/meta/recipes-core/glib-2.0/glib-2.0_2.32.4.bb
index 85352edb23..1f8ad7d0a7 100644
--- a/meta/recipes-core/glib-2.0/glib-2.0_2.32.4.bb
+++ b/meta/recipes-core/glib-2.0/glib-2.0_2.32.4.bb
@@ -1,6 +1,6 @@
require glib.inc
-PR = "r1"
+PR = "r2"
PE = "1"
DEPENDS += "libffi python-argparse-native zlib"
@@ -22,15 +22,12 @@ SRC_URI[sha256sum] = "a5d742a4fda22fb6975a8c0cfcd2499dd1c809b8afd4ef709bda4d11b1
SRC_URI_append_virtclass-native = " file://glib-gettextize-dir.patch"
BBCLASSEXTEND = "native nativesdk"
-PERLPATH = "${bindir}/env perl"
-PERLPATH_virtclass-native = "/usr/bin/env perl"
-PERLPATH_virtclass-nativesdk = "/usr/bin/env perl"
-
do_configure_prepend() {
- # missing ${topdir}/gtk-doc.make and --disable-gtk-doc* is not enough, because it calls gtkdocize (not provided by gtk-doc-native)
- sed -i '/^docs/d' ${S}/configure.ac
- sed -i 's/SUBDIRS = . m4macros glib gmodule gthread gobject gio tests po docs/SUBDIRS = . m4macros glib gmodule gthread gobject gio tests po/g' ${S}/Makefile.am
- sed -i -e "s:TEST_PROGS += gdbus-serialization::g" ${S}/gio/tests/Makefile.am
+ # missing ${topdir}/gtk-doc.make and --disable-gtk-doc* is not enough, because it calls gtkdocize (not provided by gtk-doc-native)
+ sed -i '/^docs/d' ${S}/configure.ac
+ sed -i 's/SUBDIRS = . m4macros glib gmodule gthread gobject gio tests po docs/SUBDIRS = . m4macros glib gmodule gthread gobject gio tests po/g' ${S}/Makefile.am
+ sed -i -e "s:TEST_PROGS += gdbus-serialization::g" ${S}/gio/tests/Makefile.am
+ sed -i -e '1s,#!.*,#!${USRBINPATH}/env python,' ${S}/gio/gdbus-2.0/codegen/gdbus-codegen.in
}
do_install_append() {
@@ -44,6 +41,6 @@ do_install_append() {
# Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
# for target as /usr/bin/perl, so fix it to /usr/bin/perl.
if [ -f ${D}${bindir}/glib-mkenums ]; then
- sed -i -e '1s,#!.*perl,#! ${PERLPATH},' ${D}${bindir}/glib-mkenums
+ sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/glib-mkenums
fi
}
diff --git a/meta/recipes-core/glib-2.0/glib.inc b/meta/recipes-core/glib-2.0/glib.inc
index 9ae02d9456..2f48e27f0e 100644
--- a/meta/recipes-core/glib-2.0/glib.inc
+++ b/meta/recipes-core/glib-2.0/glib.inc
@@ -31,7 +31,6 @@ EXTRA_OECONF = "--disable-debug --enable-included-printf=no ${CORECONF}"
EXTRA_OECONF_virtclass-native = "${CORECONF}"
EXTRA_OECONF_linuxstdbase = "--enable-included-printf=no ${CORECONF}"
-
FILES_${PN} = "${libdir}/lib*${SOLIBS} ${datadir}/glib-2.0/schemas \
${datadir}/glib-2.0/gettext/mkinstalldirs ${datadir}/glib-2.0/gettext/po/Makefile.in.in"
FILES_${PN}-dev += "${libdir}/glib-2.0/include \
diff --git a/meta/recipes-devtools/autoconf/autoconf.inc b/meta/recipes-devtools/autoconf/autoconf.inc
index 3ae98c8407..2c077011f8 100644
--- a/meta/recipes-devtools/autoconf/autoconf.inc
+++ b/meta/recipes-devtools/autoconf/autoconf.inc
@@ -17,10 +17,6 @@ SRC_URI = "${GNU_MIRROR}/autoconf/autoconf-${PV}.tar.bz2 \
inherit autotools
-PERLPATH = "${bindir}/perl"
-PERLPATH_virtclass-native = "/usr/bin/perl"
-PERLPATH_virtclass-nativesdk = "/usr/bin/perl"
-
do_install_append() {
rm -rf ${D}${datadir}/emacs
@@ -28,8 +24,8 @@ do_install_append() {
# for target as /usr/bin/perl, so fix it to /usr/bin/perl.
for i in autoheader autom4te autoreconf autoscan autoupdate ifnames; do
if [ -f ${D}${bindir}/$i ]; then
- sed -i -e '1s,#!.*perl,#! ${PERLPATH},' \
- -e 's,exec .*/bin/perl \(.*\) exec .*/bin/perl \(.*\),exec ${PERLPATH} \1 exec ${PERLPATH} \2,' \
+ sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/perl,' \
+ -e 's,exec .*/bin/perl \(.*\) exec .*/bin/perl \(.*\),exec ${USRBINPATH}/perl \1 exec ${USRBINPATH}/perl \2,' \
${D}${bindir}/$i
fi
done
diff --git a/meta/recipes-devtools/automake/automake_1.12.1.bb b/meta/recipes-devtools/automake/automake_1.12.1.bb
index c2bc6a3068..a1e37d471c 100644
--- a/meta/recipes-devtools/automake/automake_1.12.1.bb
+++ b/meta/recipes-devtools/automake/automake_1.12.1.bb
@@ -34,10 +34,6 @@ PATHFIXPATCH = "file://path_prog_fixes.patch"
PATHFIXPATCH_virtclass-native = ""
PATHFIXPATCH_virtclass-nativesdk = ""
-PERLPATH = "${bindir}/perl"
-PERLPATH_virtclass-native = "/usr/bin/perl"
-PERLPATH_virtclass-nativesdk = "/usr/bin/perl"
-
SRC_URI += "${PATHFIXPATCH} \
file://prefer-cpio-over-pax-for-ustar-archives.patch \
file://python-libdir.patch \
@@ -56,8 +52,8 @@ do_install () {
# for target as /usr/bin/perl, so fix it to /usr/bin/perl.
for i in aclocal aclocal-1.11 automake automake-1.11; do
if [ -f ${D}${bindir}/$i ]; then
- sed -i -e '1s,#!.*perl,#! ${PERLPATH},' \
- -e 's,exec .*/bin/perl \(.*\) exec .*/bin/perl \(.*\),exec ${PERLPATH} \1 exec ${PERLPATH} \2,' \
+ sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/perl,' \
+ -e 's,exec .*/bin/perl \(.*\) exec .*/bin/perl \(.*\),exec ${USRBINPATH}/perl \1 exec ${USRBINPATH}/perl \2,' \
${D}${bindir}/$i
fi
done
diff --git a/meta/recipes-devtools/quilt/quilt_0.60.bb b/meta/recipes-devtools/quilt/quilt_0.60.bb
index 89c3f84f39..d866032188 100644
--- a/meta/recipes-devtools/quilt/quilt_0.60.bb
+++ b/meta/recipes-devtools/quilt/quilt_0.60.bb
@@ -9,15 +9,12 @@ PR = "r1"
CACHED_CONFIGUREVARS += "ac_cv_path_BASH=${base_bindir}/bash"
-PERLPATH = "${bindir}/env perl"
-PERLPATH_virtclass-nativesdk = "/usr/bin/env perl"
-
# fix build-distro specific perl path in the target perl scripts
do_install_append() {
for perlscript in ${D}${datadir}/quilt/scripts/remove-trailing-ws ${D}${datadir}/quilt/scripts/dependency-graph ${D}${datadir}/quilt/scripts/edmail ${D}${bindir}/guards
do
if [ -f $perlscript ]; then
- sed -i -e '1s,#!.*perl,#! ${PERLPATH},' $perlscript
+ sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' $perlscript
fi
done
}
diff --git a/meta/recipes-extended/groff/groff_1.20.1.bb b/meta/recipes-extended/groff/groff_1.20.1.bb
index c5a475a348..c7da1b4178 100644
--- a/meta/recipes-extended/groff/groff_1.20.1.bb
+++ b/meta/recipes-extended/groff/groff_1.20.1.bb
@@ -18,10 +18,6 @@ DEPENDS_virtclass-native = ""
inherit autotools
-PERLPATH = "${bindir}/perl"
-PERLPATH_virtclass-native = "/usr/bin/env perl"
-PERLPATH_virtclass-nativesdk = "/usr/bin/env perl"
-
EXTRA_OECONF = "--without-x"
PARALLEL_MAKE = ""
@@ -43,7 +39,7 @@ do_install_append() {
# for target as /usr/bin/perl, so fix it to /usr/bin/perl.
for i in afmtodit mmroff; do
if [ -f ${D}${bindir}/$i ]; then
- sed -i -e '1s,#!.*perl,#! ${PERLPATH},' ${D}${bindir}/$i
+ sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/$i
fi
done
}
@@ -53,7 +49,7 @@ do_install_append_virtclass-native() {
# for target as /usr/bin/perl, so fix it to /usr/bin/perl.
for i in afmtodit mmroff; do
if [ -f ${D}${bindir}/$i ]; then
- sed -i -e '1s,#!.*perl,#! ${PERLPATH},' ${D}${bindir}/$i
+ sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/$i
fi
done