aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Glindkamp <christian.glindkamp@taskit.de>2012-09-27 14:20:57 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-27 16:21:47 +0100
commitbf84ec0fb9a4d01ea75447c2efe8e534ce975b53 (patch)
tree44f1110fcff31974a68cc03acd6da63e07d7522f
parentd35d19b6d0844daf8ca8aa059c0aa6077c2f573a (diff)
downloadopenembedded-core-bf84ec0fb9a4d01ea75447c2efe8e534ce975b53.tar.gz
perl: Fix nativesdk install path
Commit 38234f2e276356b1d77a87ceabc486107e336d19 tried to fix the sed expressions by anchoring the left side of the search regexp to prevent $prefix$prefix type expression in the perl config. For nativesdk this is not enough. Adding anchors on both side fixes this. Signed-off-by: Christian Glindkamp <christian.glindkamp@taskit.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/perl/perl_5.14.2.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.14.2.bb b/meta/recipes-devtools/perl/perl_5.14.2.bb
index 3c1360f9a3..00098553dd 100644
--- a/meta/recipes-devtools/perl/perl_5.14.2.bb
+++ b/meta/recipes-devtools/perl/perl_5.14.2.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
# We need gnugrep (for -I)
DEPENDS = "virtual/db grep-native"
DEPENDS += "gdbm zlib"
-PR = "r9"
+PR = "r10"
# 5.10.1 has Module::Build built-in
PROVIDES += "libmodule-build-perl"
@@ -150,9 +150,9 @@ do_configure() {
-e 's,@ARCH@-thread-multi,,g' \
-e 's,@ARCH@,${TARGET_ARCH}-${TARGET_OS},g' \
-e 's,@STAGINGDIR@,${STAGING_DIR_HOST},g' \
- -e "s%\([ \"^\',=]\+\)/usr/include%\1${STAGING_INCDIR}%g" \
- -e "s%\([ \"^\',=]\+\)/usr/lib/%\1${libdir}/%g" \
- -e "s%\([ \"^\',=]\+\)/usr/%\1${exec_prefix}/%g" \
+ -e "s%\([ \"^\',=]\+\)/usr/include\([ \"^\',=]\+\)%\1${STAGING_INCDIR}\2%g" \
+ -e "s%\([ \"^\',=]\+\)/usr/lib/\([ \"^\',=]\+\)%\1${libdir}/\2%g" \
+ -e "s%\([ \"^\',=]\+\)/usr/\([ \"^\',=]\+\)%\1${exec_prefix}/\2%g" \
-e "s%/perl5%/perl%g" \
config.sh-${TARGET_ARCH}-${TARGET_OS}