aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-07-25 14:34:27 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-27 14:07:22 +0100
commit21a57b98ff5091a5563c00093081297a6c586208 (patch)
tree6016de5843d11c611430a6c0f163eaa62178eff4
parent08f57808b82599ed32fdc2fb9ec2c6491465c520 (diff)
downloadopenembedded-core-21a57b98ff5091a5563c00093081297a6c586208.tar.gz
eglibc: Add patch to add sys/resource.h to wait.h
This is needed for the older kernel perf tools to build correctly, as noted in the patch new perf tools have sys/resource.h included directly. Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-core/eglibc/eglibc-2.16/add_resource_h_to_wait_h.patch20
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.16.bb3
2 files changed, 22 insertions, 1 deletions
diff --git a/meta/recipes-core/eglibc/eglibc-2.16/add_resource_h_to_wait_h.patch b/meta/recipes-core/eglibc/eglibc-2.16/add_resource_h_to_wait_h.patch
new file mode 100644
index 0000000000..f5023c08d4
--- /dev/null
+++ b/meta/recipes-core/eglibc/eglibc-2.16/add_resource_h_to_wait_h.patch
@@ -0,0 +1,20 @@
+The older versions of perf still require sys/resource.h to be
+present in this header, the newer version of perf in 3.2 and
+beyond directly include sys/resource.h
+
+Upstream-Status: Inapproriate [older kernel/perf specific]
+
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+
+Index: libc/posix/sys/wait.h
+===================================================================
+--- libc.orig/posix/sys/wait.h
++++ libc/posix/sys/wait.h
+@@ -28,6 +28,7 @@
+ __BEGIN_DECLS
+
+ #include <signal.h>
++#include <sys/resource.h>
+
+ /* These macros could also be defined in <stdlib.h>. */
+ #if !defined _STDLIB_H || (!defined __USE_XOPEN && !defined __USE_XOPEN2K8)
diff --git a/meta/recipes-core/eglibc/eglibc_2.16.bb b/meta/recipes-core/eglibc/eglibc_2.16.bb
index 8fa5451dac..f9a8f6da68 100644
--- a/meta/recipes-core/eglibc/eglibc_2.16.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.16.bb
@@ -3,7 +3,7 @@ require eglibc.inc
SRCREV = "19383"
DEPENDS += "gperf-native"
-PR = "r3"
+PR = "r4"
PR_append = "+svnr${SRCPV}"
EGLIBC_BRANCH="eglibc-2_16"
@@ -24,6 +24,7 @@ SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};protocol=h
file://rpc-bootstrap.patch \
file://e500-math_private.patch \
file://fileops-without-wchar-io.patch \
+ file://add_resource_h_to_wait_h.patch \
"
LIC_FILES_CHKSUM = "file://LICENSES;md5=98a1128c4b58120182cbea3b1752d8b9 \
file://COPYING;md5=393a5ca445f6965873eca0259a17f833 \