summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorakash hadke <akash.hadke@kpit.com>2020-11-10 12:13:55 +0530
committerSteve Sakoman <steve@sakoman.com>2020-11-10 08:55:45 -1000
commitfde72d75175d2a258e5095addd73d3da0998fc3f (patch)
tree50d726190677ec22501343cfdcd522ad46ab356f
parent2237b8a536c8c13ad59d7e93d96f6602881dc4f2 (diff)
downloadopenembedded-core-fde72d75175d2a258e5095addd73d3da0998fc3f.tar.gz
systemd: udev SECLABEL{selinux} crash fix
Adding SECLABEL{selinux}="some value" causes systemd-udev to crash. So applied below available patch to fix the issue. systemd-udev-seclabel-options-crash-fix.patch Link: https://github.com/systemd/systemd/commit/0335d110afc08baf47d76b7011ce02510dfdd524.patch Signed-off-by: akash hadke <akash.hadke@kpit.com> Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-core/systemd/systemd/systemd-udev-seclabel-options-crash-fix.patch30
-rw-r--r--meta/recipes-core/systemd/systemd_244.3.bb1
2 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd/systemd-udev-seclabel-options-crash-fix.patch b/meta/recipes-core/systemd/systemd/systemd-udev-seclabel-options-crash-fix.patch
new file mode 100644
index 0000000000..27b2b60fad
--- /dev/null
+++ b/meta/recipes-core/systemd/systemd/systemd-udev-seclabel-options-crash-fix.patch
@@ -0,0 +1,30 @@
+From 0335d110afc08baf47d76b7011ce02510dfdd524 Mon Sep 17 00:00:00 2001
+From: Valery0xff <valery.chernous@gmail.com>
+Date: Wed, 11 Mar 2020 02:20:36 +0200
+Subject: [PATCH] udev: fix SECLABEL{selinux} issue (#15064)
+
+Add SECLABEL{selinux}="some value" cause udevadm crash
+systemd-udevd[x]: Worker [x] terminated by signal 11 (SEGV)
+
+It happens since 25de7aa7b90 (Yu Watanabe 2019-04-25 01:21:11 +0200)
+when udev rules processing changed to token model. Yu forgot store
+attr to SECLABEL token so fix it.
+---
+ src/udev/udev-rules.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Upstream-Status: Backport [https://github.com/systemd/systemd/commit/0335d110afc08baf47d76b7011ce02510dfdd524.patch]
+---
+diff --git a/src/udev/udev-rules.c b/src/udev/udev-rules.c
+index b9b350d1ef..b990f68e93 100644
+--- a/src/udev/udev-rules.c
++++ b/src/udev/udev-rules.c
+@@ -921,7 +921,7 @@ static int parse_token(UdevRules *rules, const char *key, char *attr, UdevRuleOp
+ op = OP_ASSIGN;
+ }
+
+- r = rule_line_add_token(rule_line, TK_A_SECLABEL, op, value, NULL);
++ r = rule_line_add_token(rule_line, TK_A_SECLABEL, op, value, attr);
+ } else if (streq(key, "RUN")) {
+ if (is_match || op == OP_REMOVE)
+ return log_token_invalid_op(rules, key);
diff --git a/meta/recipes-core/systemd/systemd_244.3.bb b/meta/recipes-core/systemd/systemd_244.3.bb
index 850d64e8b0..64e3b18333 100644
--- a/meta/recipes-core/systemd/systemd_244.3.bb
+++ b/meta/recipes-core/systemd/systemd_244.3.bb
@@ -21,6 +21,7 @@ SRC_URI += "file://touchscreen.rules \
file://0001-binfmt-Don-t-install-dependency-links-at-install-tim.patch \
file://0003-implment-systemd-sysv-install-for-OE.patch \
file://CVE-2020-13776.patch \
+ file://systemd-udev-seclabel-options-crash-fix.patch \
"
# patches needed by musl