summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2019-09-09 13:25:19 +0300
committerArmin Kuster <akuster808@gmail.com>2019-09-29 21:38:22 -0700
commit9a271cf62d7fc7f2f15c3287831383c2cb3b5dd5 (patch)
tree1efcaf2cc20e1f0ca1df2d9a9cb96f618d6af64e
parentef7a387c8045af08e5db171e944656b9bf15f598 (diff)
downloadopenembedded-core-9a271cf62d7fc7f2f15c3287831383c2cb3b5dd5.tar.gz
libxcrypt: Fix the build with -Os
| In file included from ../git/lib/alg-des.c:66: | ../git/lib/alg-des.c: In function '_crypt_des_set_key': | ../git/lib/byteorder.h:24:1: error: inlining failed in call to 'be32_to_cpu': call is unlikely and code size would grow [-Werror=inline] | be32_to_cpu (const unsigned char *buf) | ^~~~~~~~~~~ | ../git/lib/alg-des.c:81:13: note: called from here | rawkey1 = be32_to_cpu (&key[4]); | ^~~~~~~~~~~~~~~~~~~~~ Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-core/libxcrypt/libxcrypt.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-core/libxcrypt/libxcrypt.bb b/meta/recipes-core/libxcrypt/libxcrypt.bb
index 3b9af6d739..a712e72914 100644
--- a/meta/recipes-core/libxcrypt/libxcrypt.bb
+++ b/meta/recipes-core/libxcrypt/libxcrypt.bb
@@ -24,7 +24,7 @@ FILES_${PN} = "${libdir}/libcrypt*.so.* ${libdir}/libcrypt-*.so ${libdir}/libowc
S = "${WORKDIR}/git"
BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE} -std=gnu99"
-TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir} -Wno-error=missing-attributes"
-CPPFLAGS_append_class-nativesdk = " -Wno-error=missing-attributes"
+TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir} -Wno-error"
+CPPFLAGS_append_class-nativesdk = " -Wno-error"
BBCLASSEXTEND = "nativesdk"