summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2017-04-19 15:03:57 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-04-20 07:54:08 +0100
commit705669f8221027b525773a512beb25a7ea5f0275 (patch)
treeddbb9d32174dec7671ac44a138414bfa90886e25
parentd0d3abdf9e2dec57f3849813faa5e7e3d34b83a4 (diff)
downloadopenembedded-core-705669f8221027b525773a512beb25a7ea5f0275.tar.gz
libsdl2: fix build failures on powerpc
Backport patch from upstream to fix build failures on ppc and ppc64. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-graphics/libsdl2/libsdl2/fix-build-failure-on-ppc.patch50
-rw-r--r--meta/recipes-graphics/libsdl2/libsdl2_2.0.5.bb1
2 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libsdl2/libsdl2/fix-build-failure-on-ppc.patch b/meta/recipes-graphics/libsdl2/libsdl2/fix-build-failure-on-ppc.patch
new file mode 100644
index 0000000000..1520bcfb6a
--- /dev/null
+++ b/meta/recipes-graphics/libsdl2/libsdl2/fix-build-failure-on-ppc.patch
@@ -0,0 +1,50 @@
+Upstream-Status: Backport [https://hg.libsdl.org/SDL/rev/5184186d4366]
+
+Backport patch from upstream to fix build failures on ppc and ppc64.
+
+Signed-off-by: Kai Kang <kai.kang@windriver.com>
+---
+# HG changeset patch
+# User Sam Lantinga <slouken@libsdl.org>
+# Date 1477159315 25200
+# Node ID 5184186d4366169617b434f5b71c618a7035cde4
+# Parent 71d4148e32de5088c4bc2f04c1e5ded647a2bf82
+Fixed bug 3466 - Can't build 2.0.5 on ppc64
+
+/home/fedora/SDL2-2.0.5/src/video/SDL_blit_N.c: In function 'calc_swizzle32':
+/home/fedora/SDL2-2.0.5/src/video/SDL_blit_N.c:127:5: error: ISO C90 forbids mixed declarations and code [-Werror=declaration-after-statement]
+ const vector unsigned char plus = VECUINT8_LITERAL(0x00, 0x00, 0x00, 0x00,
+ ^
+
+diff -r 71d4148e32de -r 5184186d4366 src/video/SDL_blit_N.c
+--- a/src/video/SDL_blit_N.c Wed Oct 19 21:22:42 2016 -0700
++++ b/src/video/SDL_blit_N.c Sat Oct 22 11:01:55 2016 -0700
+@@ -118,12 +118,6 @@
+ 16, 8, 0, 24,
+ 0, NULL
+ };
+- if (!srcfmt) {
+- srcfmt = &default_pixel_format;
+- }
+- if (!dstfmt) {
+- dstfmt = &default_pixel_format;
+- }
+ const vector unsigned char plus = VECUINT8_LITERAL(0x00, 0x00, 0x00, 0x00,
+ 0x04, 0x04, 0x04, 0x04,
+ 0x08, 0x08, 0x08, 0x08,
+@@ -136,6 +130,14 @@
+ Uint32 gmask = RESHIFT(srcfmt->Gshift) << (dstfmt->Gshift);
+ Uint32 bmask = RESHIFT(srcfmt->Bshift) << (dstfmt->Bshift);
+ Uint32 amask;
++
++ if (!srcfmt) {
++ srcfmt = &default_pixel_format;
++ }
++ if (!dstfmt) {
++ dstfmt = &default_pixel_format;
++ }
++
+ /* Use zero for alpha if either surface doesn't have alpha */
+ if (dstfmt->Amask) {
+ amask =
+
diff --git a/meta/recipes-graphics/libsdl2/libsdl2_2.0.5.bb b/meta/recipes-graphics/libsdl2/libsdl2_2.0.5.bb
index d747cf18f0..12d3aaf6f0 100644
--- a/meta/recipes-graphics/libsdl2/libsdl2_2.0.5.bb
+++ b/meta/recipes-graphics/libsdl2/libsdl2_2.0.5.bb
@@ -19,6 +19,7 @@ SRC_URI = " \
file://linkage.patch \
file://0001-prepend-our-sysroot-path-so-that-make-finds-our-wayl.patch \
file://0002-Avoid-finding-build-host-s-wayland-scanner.patch \
+ file://fix-build-failure-on-ppc.patch \
"
S = "${WORKDIR}/SDL2-${PV}"