summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLianhao Lu <lianhao.lu@intel.com>2012-01-18 15:03:36 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-10 17:04:44 +0000
commitb175fb31d3a1293f8ab09a2d7a9e310211a4f6aa (patch)
tree5f025c68fcbf2aec8ddeb731fad6378902a56c78
parentb1a4d1a912af39dc3be7433a1e2ed4c48d5ffb93 (diff)
downloadopenembedded-core-b175fb31d3a1293f8ab09a2d7a9e310211a4f6aa.tar.gz
adt-installer: install autoconf(/automake)-nativesdk
[YOCTO #1909] Install autoconf-nativesdk and automake-nativesdk to host. (From OE-Core rev: 0b3842f5c3c1587d25e70bc8223e2b144b9043cb) Signed-off-by: Lianhao Lu <lianhao.lu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rwxr-xr-xmeta/recipes-devtools/installer/adt-installer/scripts/adt_installer_internal18
-rw-r--r--meta/recipes-devtools/installer/adt-installer_1.0.bb2
2 files changed, 7 insertions, 13 deletions
diff --git a/meta/recipes-devtools/installer/adt-installer/scripts/adt_installer_internal b/meta/recipes-devtools/installer/adt-installer/scripts/adt_installer_internal
index 870931e37b..6201095117 100755
--- a/meta/recipes-devtools/installer/adt-installer/scripts/adt_installer_internal
+++ b/meta/recipes-devtools/installer/adt-installer/scripts/adt_installer_internal
@@ -91,18 +91,12 @@ check_result
OPKG_INSTALL_CMD="$OPKG_CMD "
OPKG_INSTALL_NATIVE_CMD="$OPKG_INSTALL_CMD -f $OPKG_CONFIG_FILE -o $NATIVE_INSTALL_DIR install"
-echo_info "Installing pseudo nativesdk ...\n"
-$OPKG_INSTALL_NATIVE_CMD pseudo-nativesdk &>> $YOCTOADT_INSTALL_LOG_FILE
-check_result
-echo_info "Installing opkg nativesdk ...\n"
-$OPKG_INSTALL_NATIVE_CMD opkg-nativesdk &>> $YOCTOADT_INSTALL_LOG_FILE
-check_result
-echo_info "Installing pkgconfig nativesdk ...\n"
-$OPKG_INSTALL_NATIVE_CMD pkgconfig-nativesdk &>> $YOCTOADT_INSTALL_LOG_FILE
-check_result
-echo_info "Installing libtool nativesdk ...\n"
-$OPKG_INSTALL_NATIVE_CMD libtool-nativesdk &>> $YOCTOADT_INSTALL_LOG_FILE
-check_result
+BASE_HOSTSDK_PKGNAMES="pseudo opkg pkgconfig libtool autoconf automake"
+for pkg in $BASE_HOSTSDK_PKGNAMES; do
+ echo_info "Installing ${pkg} nativesdk ...\n"
+ $OPKG_INSTALL_NATIVE_CMD ${pkg}-nativesdk &>> $YOCTOADT_INSTALL_LOG_FILE
+ check_result
+done
for native_target_type in $YOCTOADT_TARGETS; do
native_target_type=`echo "$native_target_type" | sed -e 's/x86_64/x86-64/' -e 's/ppc/powerpc/' -e 's/x86$/i586/'`
diff --git a/meta/recipes-devtools/installer/adt-installer_1.0.bb b/meta/recipes-devtools/installer/adt-installer_1.0.bb
index 74e1b9f2ba..e960165c6d 100644
--- a/meta/recipes-devtools/installer/adt-installer_1.0.bb
+++ b/meta/recipes-devtools/installer/adt-installer_1.0.bb
@@ -31,7 +31,7 @@ ALLOW_EMPTY = "1"
PACKAGES = ""
PACKAGE_ARCH = "all"
-PR = "r4"
+PR = "r5"
ADT_DEPLOY = "${TMPDIR}/deploy/sdk/"
ADT_DIR = "${WORKDIR}/adt-installer/"