summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-10-14 11:42:37 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-10-14 11:46:39 +0100
commit9eb2de9163791e1cf02a1fbf94da1ed55d8378c5 (patch)
treea269d48a8a52c939060e8d0cd67833ec5b9c38dc
parenta2337a34358b017a3e4311a2647165da2d8b54d3 (diff)
downloadopenembedded-core-9eb2de9163791e1cf02a1fbf94da1ed55d8378c5.tar.gz
Revert "meta-toolchain: Update the way ld.so.cache is handled"
This change didn't work as expected as ld.so.cache doesn't preseve any search path ordering, therefore revert the change. This reverts commit b2c3ce6d17520d43b10777dd306449876cb40819.
-rw-r--r--meta/classes/toolchain-scripts.bbclass4
-rw-r--r--meta/recipes-tbd/meta/meta-toolchain.bb11
2 files changed, 2 insertions, 13 deletions
diff --git a/meta/classes/toolchain-scripts.bbclass b/meta/classes/toolchain-scripts.bbclass
index 9c6fe67d49..c393d99644 100644
--- a/meta/classes/toolchain-scripts.bbclass
+++ b/meta/classes/toolchain-scripts.bbclass
@@ -6,10 +6,6 @@ toolchain_create_sdk_env_script () {
script=${SDK_OUTPUT}/${SDKPATH}/environment-setup-${MULTIMACH_TARGET_SYS}
rm -f $script
touch $script
- echo 'if [ ! -e ${SDKPATHNATIVE}/etc/ld.so.cache ]; then' >> $script
- echo ' echo "Please run ${SDKPATH}/postinstall as root before using the toolchain"' >> $script
- echo ' exit 1' >> $script
- echo 'fi' >> $script
echo 'export PATH=${SDKPATHNATIVE}${bindir_nativesdk}:${SDKPATHNATIVE}${bindir_nativesdk}/${MULTIMACH_TARGET_SYS}:$PATH' >> $script
echo 'export PKG_CONFIG_SYSROOT_DIR=${SDKTARGETSYSROOT}' >> $script
echo 'export PKG_CONFIG_PATH=${SDKTARGETSYSROOT}${libdir}/pkgconfig' >> $script
diff --git a/meta/recipes-tbd/meta/meta-toolchain.bb b/meta/recipes-tbd/meta/meta-toolchain.bb
index 633f5f1990..2fab8f94b2 100644
--- a/meta/recipes-tbd/meta/meta-toolchain.bb
+++ b/meta/recipes-tbd/meta/meta-toolchain.bb
@@ -72,15 +72,8 @@ do_populate_sdk() {
#rm -f ${SDK_OUTPUT}/${SDKPATHNATIVE}/lib/*.la
rm -f ${SDK_OUTPUT}/${SDKPATHNATIVE}${libdir_nativesdk}/*.la
- # Create an appropriate setup so the dynamic loader can find libs in
- # both the host system and the toolchain directories
- echo ${SDKPATHNATIVE}${libdir} > ${SDK_OUTPUT}/${SDKPATHNATIVE}/etc/ld.so.conf
- echo ${SDKPATHNATIVE}${base_libdir} >> ${SDK_OUTPUT}/${SDKPATHNATIVE}/etc/ld.so.conf
- echo "include /etc/ld.so.conf" >> ${SDK_OUTPUT}/${SDKPATHNATIVE}/etc/ld.so.conf
- echo "#!/bin/sh" > ${SDK_OUTPUT}/${SDKPATH}/postinstall
- echo "ldconfig -f ${SDKPATHNATIVE}/etc/ld.so.conf -C /${SDKPATHNATIVE}/etc/ld.so.cache" >> ${SDK_OUTPUT}/${SDKPATH}/postinstall
- chmod a+x ${SDK_OUTPUT}/${SDKPATH}/postinstall
-
+ # Link the ld.so.cache file into the hosts filesystem
+ ln -s /etc/ld.so.cache ${SDK_OUTPUT}/${SDKPATHNATIVE}/etc/ld.so.cache
# Setup site file for external use
siteconfig=${SDK_OUTPUT}/${SDKPATH}/site-config-${MULTIMACH_TARGET_SYS}