summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-22 22:36:06 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-30 16:39:06 +0000
commit4c75318b75c4776cc469cc2c6511596bc7befbb4 (patch)
tree0199d87b0faf23573e4d76fcb0371e095b39efcd
parenta300e9e45f4570f0aa47fb3fabcee95433ffad99 (diff)
downloadopenembedded-core-4c75318b75c4776cc469cc2c6511596bc7befbb4.tar.gz
opkg: Fix installation order in feeds with mutiple providers of packages
If two packages were available of differing priority, this would confuse opkg and it was ignoring the dependency in the new dependency ordering code. This changes it not to ignore these cases by setting the badly named 'quiet' parameter accordingly. (From OE-Core rev: c38693f78c968ab5f4bb557c20d1c8c55393ed6b) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/opkg/opkg/fix_installorder.patch2
-rw-r--r--meta/recipes-devtools/opkg/opkg_svn.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/opkg/opkg/fix_installorder.patch b/meta/recipes-devtools/opkg/opkg/fix_installorder.patch
index e782ce738d..5e6c40d649 100644
--- a/meta/recipes-devtools/opkg/opkg/fix_installorder.patch
+++ b/meta/recipes-devtools/opkg/opkg/fix_installorder.patch
@@ -144,7 +144,7 @@ Index: trunk/libopkg/pkg_depends.c
+ pkg_t *satisfying_pkg =
+ pkg_hash_fetch_best_installation_candidate(satisfying_apkg,
+ pkg_installed_and_constraint_satisfied,
-+ dependence_to_satisfy, 1);
++ dependence_to_satisfy, 0);
+ /* Being that I can't test constraing in pkg_hash, I will test it here */
+ if (satisfying_pkg != NULL && satisfying_pkg != pkg) {
+ if (pkg_constraint_satisfied(satisfying_pkg, dependence_to_satisfy) && satisfying_pkg->state_want == SW_INSTALL)
diff --git a/meta/recipes-devtools/opkg/opkg_svn.bb b/meta/recipes-devtools/opkg/opkg_svn.bb
index 00591d168f..f5f540d78e 100644
--- a/meta/recipes-devtools/opkg/opkg_svn.bb
+++ b/meta/recipes-devtools/opkg/opkg_svn.bb
@@ -21,7 +21,7 @@ S = "${WORKDIR}/trunk"
SRCREV = "633"
PV = "0.1.8+svnr${SRCPV}"
-PR = "r4"
+PR = "r5"
PACKAGES =+ "libopkg${PKGSUFFIX}-dev libopkg${PKGSUFFIX} update-alternatives-cworth${PKGSUFFIX}"