summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-12-10 12:22:38 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-30 16:39:05 +0000
commit007bbb23808cc5b036829915e3dfa04f590a05d8 (patch)
treeffa624c5230e2f6b3bf294b21212d65e2af3f6fa
parent44d9e208c97ec1e3c5ba0a8dc6c10cef12dc270d (diff)
downloadopenembedded-core-007bbb23808cc5b036829915e3dfa04f590a05d8.tar.gz
texinfo: fix compile failure due target makedoc binary being used
Need to have the texinfo-native build and install a host sysroot makedoc binary and then patch the target build to use this binary. This requires that we don't ASSUME_PROVIDED texinfo-native any longer since we need to install this makedoc tool which is not part of the normal distrubtion. [YOCTO #1664] (From OE-Core rev: 9fa98de54a73465f06484ba863eccf1e07cc1e2a) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/texinfo/texinfo-4.13a/use_host_makedoc.patch37
-rw-r--r--meta/recipes-extended/texinfo/texinfo_4.13a.bb11
2 files changed, 46 insertions, 2 deletions
diff --git a/meta/recipes-extended/texinfo/texinfo-4.13a/use_host_makedoc.patch b/meta/recipes-extended/texinfo/texinfo-4.13a/use_host_makedoc.patch
new file mode 100644
index 0000000000..db41f1a47e
--- /dev/null
+++ b/meta/recipes-extended/texinfo/texinfo-4.13a/use_host_makedoc.patch
@@ -0,0 +1,37 @@
+This patch requires that we also enable building of the
+texinfo-native recipe which will install the makedoc tool
+for the host machine.
+
+This patch simply uses the newly installed makedoc tool from
+sysroot.
+
+Upstream-Status: Inappropriate [OE-Specific]
+
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+
+Index: texinfo-4.13/info/Makefile.am
+===================================================================
+--- texinfo-4.13.orig/info/Makefile.am 2008-05-22 05:11:33.000000000 -0700
++++ texinfo-4.13/info/Makefile.am 2011-12-10 12:55:53.604440118 -0800
+@@ -75,7 +75,7 @@
+ # more than once.
+ funs.h: makedoc$(EXEEXT) $(cmd_sources)
+ rm -f $(generated_sources)
+- $(top_builddir)/$(native_tools)/info/makedoc $(cmd_sources)
++ makedoc $(cmd_sources)
+
+ # The following hack is necessary to hint make before the automatic
+ # dependencies are built.
+Index: texinfo-4.13/doc/Makefile.am
+===================================================================
+--- texinfo-4.13.orig/doc/Makefile.am 2008-09-18 11:31:56.000000000 -0700
++++ texinfo-4.13/doc/Makefile.am 2011-12-10 13:04:09.216457601 -0800
+@@ -19,7 +19,7 @@
+
+ # Use the programs built in our distribution, taking account of possible
+ # cross-compiling.
+-MAKEINFO = $(top_builddir)/$(native_tools)/makeinfo/makeinfo
++MAKEINFO = makeinfo
+
+ # We'd also like to use something like this, but Automake calls
+ # "install-info" directly.
diff --git a/meta/recipes-extended/texinfo/texinfo_4.13a.bb b/meta/recipes-extended/texinfo/texinfo_4.13a.bb
index 9f1c04ace1..f205d4e04d 100644
--- a/meta/recipes-extended/texinfo/texinfo_4.13a.bb
+++ b/meta/recipes-extended/texinfo/texinfo_4.13a.bb
@@ -6,11 +6,14 @@ HOMEPAGE = "http://www.gnu.org/software/texinfo/"
SECTION = "console/utils"
LICENSE = "GPLv3+"
LIC_FILES_CHKSUM = "file://COPYING;md5=adefda309052235aa5d1e99ce7557010"
-PR = "r1"
+PR = "r2"
DEPENDS = "zlib ncurses texinfo-native"
DEPENDS_virtclass-native = "zlib-native ncurses-native"
+TARGET_PATCH = "file://use_host_makedoc.patch"
+TARGET_PATCH_virtclass-native = ""
+
SRC_URI = "${GNU_MIRROR}/texinfo/texinfo-${PV}.tar.gz \
file://texinfo-4.12-zlib.patch \
file://texinfo-4.13a-data_types.patch \
@@ -19,7 +22,8 @@ SRC_URI = "${GNU_MIRROR}/texinfo/texinfo-${PV}.tar.gz \
file://texinfo-4.13a-help-index-segfault.patch \
file://disable-native-tools.patch \
file://link-zip.patch \
- file://gettext-macros.patch"
+ file://gettext-macros.patch \
+ ${TARGET_PATCH}"
SRC_URI[md5sum] = "71ba711519209b5fb583fed2b3d86fcb"
SRC_URI[sha256sum] = "1303e91a1c752b69a32666a407e9fbdd6e936def4b09bc7de30f416301530d68"
@@ -39,6 +43,9 @@ do_install_append() {
mkdir -p ${D}${datadir}/${tex_texinfo}
install -p -m644 doc/texinfo.tex doc/txi-??.tex ${D}${datadir}/${tex_texinfo}
}
+do_install_append_virtclass-native() {
+ install -m 755 info/makedoc ${D}${bindir}
+}
PACKAGES += "info info-doc"