aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome
Commit message (Collapse)AuthorAgeFilesLines
* gtk-icon-utils-native: Upgrade 3.16.6 -> 3.18.2Jussi Kukkonen2015-11-251-2/+2
| | | | | Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* gtk+3: Upgrade 3.16.6 -> 3.18.2Jussi Kukkonen2015-11-252-3/+6
| | | | | | | | * Package new development tool gtk-builder-tool. * Disable colord support (for explicitness, no functional change) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* adwaita-icon-theme: Upgrade 3.16.2.1 -> 3.18.0Jussi Kukkonen2015-11-252-181/+2
| | | | | | | Remove a backported patch. Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* librsvg: Upgrade 2.40.10 -> 2.40.11Jussi Kukkonen2015-11-251-2/+2
| | | | | Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* gdk-pixbuf: Upgrade 2.30.8 -> 2.32.1Jussi Kukkonen2015-11-252-92/+2
| | | | | | | Remove a backported patch. Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* libsecret: add dependency on intltool-nativeJoe Slater2015-11-251-1/+1
| | | | | | | intltoolize is needed by configure. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* gtk+3: fix ALTERNATIVE_PRIORITY conflict with gtk+Robert Yang2015-11-161-0/+1
| | | | | | | | | | | | | | Signed-off-by: Ross Burton <ross.burton@intel.com> Conflicts: gtk+3 and gtk+ have the same priority 10 for gtk-update-icon-cache Turn up gtk+3's priority to fix the conflict. [YOCTO #8477] Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* recipes: add distro_features_check for some packagesWenzong Fan2015-11-162-2/+6
| | | | | | | | | | | * The packages that depends on gtk+3 require any of distro features from ${GTK3DISTROFEATURES} * The packages that depends on virtual/egl, virtual/libgl ... require distro feature 'opengl' Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* gnome-desktop: add xkeyboard-config dependencyPushpal Sidhu2015-10-241-1/+1
| | | | | | | | | | | | | | | | | | | | | | gnome-desktop will fail during do_configure if xkeyboard-config had not already been built. Please see the following for the error: | configure: error: Package requirements (gdk-pixbuf-2.0 >= 2.21.3 | gtk+-3.0 >= 3.3.6 | glib-2.0 >= 2.38.0 | gio-2.0 >= 2.38.0 | gsettings-desktop-schemas >= 3.5.91 | xrandr >= 1.3 | xext >= 1.1 | xkeyboard-config | iso-codes) were not met: | | No package 'xkeyboard-config' found Add dependency of xkeyboard-config to this to resolve this issue. Signed-off-by: Pushpal Sidhu <psidhu@gateworks.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* gtk+3: Do not try to initialize GL without libglJussi Kukkonen2015-10-243-1/+64
| | | | | | | | | | | | | | | | | | Gdk initialization ends up calling epoxy GLX api, which calls exit() if libGL.so.1 is not present. In practice this prevents all GTK+ applications from starting if GLX is not present. If opengl and x11 distro features are set, make gtk+3 RDEPEND on libgl. If opengl and x11 distro features are not set, use #ifdef to prevent the GL initialization. Remove libgl dependency from gtk3-demo: it can now run without libgl (although trying to run the glarea demo will exit in that case). [YOCTO #8529] Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* webkitgtk, gcr, libsecret: force ARM modeMartin Jansa2015-10-122-0/+6
| | | | | | | | | * gcr, libsecret are new since switch to gcc 5.2 * webkitgtk is old but it was removed while migrating from webkit-gtk to webkitgtl (like REQUIRED_DISTRO_FEATURES were) :/ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* gtk+3: gtk3-demo needs libglJussi Kukkonen2015-10-121-1/+1
| | | | | | | | | The demo app uses OpenGL (within a GtkGLArea): it needs a runtime dependency on a GL library. Current GTK+ can only handle full GL (libGL.so.1) so RDEPEND on libgl. Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* gnome-doc-utils: xslt - don't install MakefilesWenzong Fan2015-10-011-3/+0
| | | | | | | | | All the xml files under xslt will be installed by default, the buildtime stuffs that Makefile, Makefile.in, Makefile.am are not needed for target. Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* meta: fix build with gettext 0.16.1Robert Yang2015-10-012-2/+2
| | | | | | | | | | | | | | | | | | | | | | | | | | | The gettext 0.16.1 doesn't install any m4 files to sysroot, please see the following commit: commit 9e10db5bdfe77c0ef2aff2f1cf89958b62c294a1 Author: Christopher Larson <kergoth@gmail.com> Date: Mon Mar 17 18:10:54 2014 +0000 gettext-0.16.1: kill target m4 macros from sysroot This is aim for using gettext-native's macros(gettext-native-0.19.4), but when we set: PREFERRED_VERSION_gettext = "0.16.1" And build the recipes like pcmanfm, we would get errors when do_configure: configure:5164: error: possibly undefined macro: AM_NLS This is because autotools_copy_aclocals doesn't copy the native macros for target unless they're direct dependencies. Add gettext-native to DEPENDS will fix the problem. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* classes/meta: Add DISTRO_FEATURES check for gtk+/gtk3+Richard Purdie2015-09-298-4/+23
| | | | | | | | | | | | If you currently do a DISTRO_FEATURES_remove = "x11" with OE-Core, you see failures due to dependency problems. The work in resolving this was partially completed a while back. This adds in the markup mainly for gtk/gtk3+ recipes and means "bitbake world" will work successfully. Rather than code the gtk/gtk+ specific distro features into each recipe, a shared variable is used. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* gdk-pixbuf: Only apply native cleaning in normal task, not setsceneRichard Purdie2015-09-281-1/+1
| | | | | | | | | The previous fix works well for normal tasks since the ordering is always correct and gdk-pixbuf-native comes first. Setscene ordering is reversed so we can't rely on this there. Remove the fix in that case since it breaks more than it solves. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* librsvg: tell configure where gdk-pixbuf-query-loaders isRoss Burton2015-09-261-0/+2
| | | | | | | | Now that gdk-pixbuf-query-loaders isn't in the path, tell configure where to find it. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* gdk-pixbuf: move gdk-pixbuf-query-loaders to $libdir for multilib safetyRoss Burton2015-09-261-2/+9
| | | | | | | | | | | | | If for example gdk-pixbuf and lib32-gdk-pixbuf are in an image then only one ${bindir}/gdk-pixbuf-query-loaders will be installed, so only one variant will actually be usable. Solve this by moving gdk-pixbuf-query-loaders into ${libdir} as it's intimately tied to the library and rarely directly invoked by the user, and update the callers to use the right path. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* gdk-pixbuf: move gdk-pixbuf-pixdata to gdk-pixbuf-devRoss Burton2015-09-261-2/+2
| | | | | | | | This is a development tool, similar to gdk-pixbuf-csource, so move it to the -dev package. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* gdk-pixbuf: Avoid rebuild failuresRichard Purdie2015-09-241-0/+9
| | | | | | | | | | | | | | | | | | If gdkpixbuf-native rebuilds and there are stale (broken) modules lying around, it can fail to run the postinst. E.g. svg links to harfbuzz and if harfbuzz is removed from the sysroot but the svg loader isn't, we get a symbol linking issue. The reproducer is along the lines of build gdk-pixbuf-native along with harfbuzz-native and librsvg-native, then make a small change to the gdk-pixbuf recipe that would cause it to rebuild, clean harfbuzz-native and then build gdk-pixbuf. To fix this, when we install gdk-pixbuf, we wipe out any previous loaders. The idea is that gdk would always come first and anything else installing itself will come later and rerun the postinst if needed. We can therefore just remove any other loaders. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* gdk-pixbuf: remove redundant libx11 DEPENDS lineCarlos Rafael Giani2015-09-211-1/+0
| | | | | | | | The x11 packageconfig already takes care of the X11 dependency, and also respects the DISTRO_FEATURES Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org> Signed-off-by: Ross Burton <ross.burton@intel.com>
* adwaita-icon-theme: RREPLACE gnome-icon-themeJussi Kukkonen2015-09-161-0/+4
| | | | | | | | RREPLACE, RCONFLICT and RPROVIDE gnome-icon-theme to make on-device upgrades work. Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* epiphany: add a recipe from meta-gnomeAlexander Kanavin2015-09-142-0/+57
| | | | | | | | | | Epiphany is replacing midori as the browser in oe-core recipe set and poky distribution. (From OE-Core rev: cf1ad936487d5d068304b6e2565bfd556d81baef) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* gnome-icon-theme: remove the recipeAlexander Kanavin2015-09-122-50/+0
| | | | | | | It is not used by anything in oe-core and will be moved to meta-gnome Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* gsettings-desktop-schemas: add a recipe from meta-gnomeAlexander Kanavin2015-09-111-0/+13
| | | | | | gsettings-desktop-schemas is a dependency of epiphany Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
* gnome-desktop3: add a recipe from meta-gnomeAlexander Kanavin2015-09-111-0/+21
| | | | | | gnome-desktop3 is a dependency of epiphany Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
* libwnck3: add a recipe from meta-gnomeAlexander Kanavin2015-09-111-0/+15
| | | | | | libwnck is a dependency of epiphany Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
* gcr: add a recipe from meta-gnomeAlexander Kanavin2015-09-111-0/+18
| | | | | | gcr is a dependency of epiphany Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
* libsecret: add a recipe from meta-gnomeAlexander Kanavin2015-09-111-0/+12
| | | | | | libsecret is a dependency of webkit Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
* libunique: remove the recipeAlexander Kanavin2015-09-064-612/+0
| | | | | | | It is not used by anything in oe-core and will be moved to meta-oe Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libnotify: add (R)PROVIDES/RCONFLICTS/RREPLACES for meta-gnome's libnotifyAndreas Müller2015-09-021-0/+6
| | | | | | | Avoid package feed issues caused by removing meta-gnome's libnotify3 Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libnotify: don't inherit unnecessary distro_features_checkAlexander Kanavin2015-08-311-1/+1
| | | | | Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libnotify: update to version 0.7.6Alexander Kanavin2015-08-262-21/+12
| | | | | | | New webkit requires at least version 0.7 Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* classes/gnomebase: change tarball compression to xzAlexander Kanavin2015-08-247-8/+3
| | | | | | | | Upstream, xz has been the only format for some time now, so let's make it the default and adjust recipes that package old stuff. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* json-glib: inherit gnomebase instead of gnomeRoss Burton2015-08-241-3/+1
| | | | | | | | | There's no need to inherit gnome as it pulls in spurious dependencies for a non-graphical library, so just inherit gnomebase. Also remove the --disable-introspection option as gnomebase already does that. Signed-off-by: Ross Burton <ross.burton@intel.com>
* json-glib: enable native buildsRoss Burton2015-08-241-0/+2
| | | | Signed-off-by: Ross Burton <ross.burton@intel.com>
* gdk-pixbuf: Security Advisory - gdk-pixbuf - CVE-2015-4491Li Zhou2015-08-192-0/+90
| | | | | | | | | | | | | | pixops: Be more careful about integer overflow Integer overflow in the make_filter_table function in pixops/pixops.c in gdk-pixbuf before 2.31.5, as used in Mozilla Firefox before 40.0 and Firefox ESR 38.x before 38.2 on Linux, Google Chrome on Linux, and other products, allows remote attackers to execute arbitrary code or cause a denial of service (heap-based buffer overflow and application crash) via crafted bitmap dimensions that are mishandled during scaling. Signed-off-by: Li Zhou <li.zhou@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* librsvg: Upgrade 2.40.9 -> 2.40.10Jussi Kukkonen2015-08-162-9/+8
| | | | | | | Rebase gtk-option.patch Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* gtk-icon-utils-native: Upgrade 3.16.4 -> 3.16.6Jussi Kukkonen2015-08-091-2/+2
| | | | | Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* gtk+3: Upgrade 3.16.4 -> 3.16.6Jussi Kukkonen2015-08-092-31/+2
| | | | | | | Remove a backported patch. Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* gtk+: require either x11 or directfb DISTRO_FEATURES to be setRoss Burton2015-07-221-0/+3
| | | | | | | GTK+ needs either X11 or DirectFB, and fails with obscure errors if neither are present. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* gtk+3: fix Wayland-only buildsRoss Burton2015-07-222-0/+29
| | | | | | | | When configured with just the Wayland backend (no X11), not enough Pango headers were included. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* gnome-icon-theme: clean up icon-naming searchRoss Burton2015-07-203-52/+29
| | | | | | | | | | | Previous this recipe added an argument to specify where the icon-name-mapping binary is installed, to override a failing pkg-config call (as target pkg-config won't find native .pc files), and munged libexecdir as it likely contains PN. This is all very complicated and we have a native pkg-config binary now, so just use pkg-config-native for that section of configure.ac. Signed-off-by: Ross Burton <ross.burton@intel.com>
* gtk-icon-utils: Rename, upgrade, add binaryJussi Kukkonen2015-07-163-47/+165
| | | | | | | | | | | | | | | * Rename from gtk-update-icon-cache to gtk-icon-utils to better reflect the content. Fix references in other recipes and classes * Upgrade to GTK+ 3.16.4 * Add gtk-encode-symbolic-svg binary: it is used by icon themes (e.g. Adwaita) to generate png versions of svg icons. * Depend on librsvg-native for gtk-encode-symbolic-svg * Add a patch that removes Gdk dependency from gtk-encode-symbolic-svg: this way the native build stays slim. Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* gtk+3: Upgrade to 3.16.4Jussi Kukkonen2015-07-164-44/+130
| | | | | | | | | | | | | | | * Drop --disable-gtk2-dependency and the patch for gtk/native/Makefile.am: gtk-update-icon-cache is no longer used at build time and as a result the option was removed. * Add dependency to libepoxy * Add dependency to virtual/mesa for wayland-egl * Package new binaries gtk3-icon-browser and gtk-encode-symbolic-svg * Add a backported patch that allows server side window decorations in all cases * RRECOMMEND adwaita-icon-theme-symbolic: GTK+ widgets expect a symbolic theme to be installed Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
* adwaita-icon-theme: Add new icon theme for GTK+Jussi Kukkonen2015-07-162-0/+212
| | | | | | | | | | | Adwaita is a complete icon theme for GTK+, and the current GNOME icon theme. Most importantly it includes the symbolic icons used extensively in GTK+3 widgets. * Package icons, large icons, symbolic icons and cursors separately * Backport a build fix for the cursor theme to cut installed size by 11MB. Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
* gnome-icon-theme: inherit allarchRoss Burton2015-07-121-2/+2
| | | | | | | | | | The intltool 0.51 doesn't do compile tests in the autoconf macros, so this recipe can be allarch again. Remove dependency on target glib-2.0, it doesn't appear to be required. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libffi: fix typo in fix-libffi.la-location.patchAndre McCurdy2015-07-071-1/+1
| | | | | Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* gtk+: Upgrade 2.24.27 -> 2.24.28Jussi Kukkonen2015-06-231-2/+2
| | | | | Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* gtk-engines: Make gtk-engines-dev installable by dropping dependency to not ↵Florian Boor2015-05-211-0/+2
| | | | | | generated gtk-engines package. Signed-off-by: Ross Burton <ross.burton@intel.com>