summaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
* kmod: upgrade to 21ChenQi/kmod-21Chen Qi2015-06-261-2/+6
| | | | | | | Upgrade kmod to 21. Fix cross compilation problem. Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
* sysvinit: Only enable recipe in builds where its applicableRichard Purdie2015-06-101-0/+5
| | | | | | | | Similarly to systemd, only enable the recipe in builds where sysvinit is configured in DISTRO_FEATURES. This allows the new cleanup mechanism to handle it correctly in existing builds. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* sanity.conf: Bump minimum bitbake version to 1.27.1 for sstate changeRichard Purdie2015-06-101-1/+1
| | | | Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* sstate: Add eventhandler which cleans up stale recipe dataRichard Purdie2015-06-101-0/+65
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | "Incremental builds do not work well when renaming recipes or changing architecture" is a long standing issue which causes people considerable pain. We've struggled for a long time to come up with a way to generically address the problem. There are additional issues where removal of a layer caused data to continue to exist and additionally, changing DISTRO_FEATURES also caused problems in an existing TMPDIR. This patch attempts to address this by adding a mapping between stamp files and manifests. After parsing we can easily tell which stamp files are still reachable, if any manifest has a stamp that can no longer be reached, we can remove it. Since this code ties this to the sstate architecture list, it will not remove data from other than the current MACHINE (and its active architectures). It does not clean the sstate cache so if another build activates something which was cleaned, it should reinstall from sstate. We can also go one step further, depending on the setting of SSTATE_PRUNE_OBSOLETEWORKDIR, workdirs which are no longer active can also be removed. This avoids the buildup of many old copies of data in WORKDIR for example when versions are upgraded. The one thing which may surprise people with this change is if you remove a layer, data added by that layer will be "uninstalled" before the next build continues. I believe this is a feature and a good thing to do though. This code is safe with existing builds. If something isn't in the new index it simply isn't removed. Since changes to the sstate code trigger a rebuild, after this merges, we can assume the code will start to detect changes from that point onwards. [YOCTO #4102] Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* x264: use x86 over-ride instead of i586Andre McCurdy2015-06-081-1/+1
| | | | | | | Support i686 without needing to duplicate the i586 over-ride. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* lame: use x86 over-ride instead of i586Andre McCurdy2015-06-081-1/+1
| | | | | | | Support i686 without needing to duplicate the i586 over-ride. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* gstreamer1.0-plugins-base.inc: use x86 over-ride instead of i586Andre McCurdy2015-06-081-1/+1
| | | | | | | Support i686 without needing to duplicate the i586 over-ride. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* python-numpy: use x86 over-ride instead of i586Andre McCurdy2015-06-083-1/+1
| | | | | | | Support i686 without needing to duplicate the i586 over-ride. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* scripts/jhbuild: removeRoss Burton2015-06-0817-16010/+0
| | | | | | | Remove the jhbuild2oe script and the copies of very old GNOME modulesets as nobody has used them for a long time. Signed-off-by: Ross Burton <ross.burton@intel.com>
* libsndfile: Security Advisory - libsndfile - CVE-2014-9496Yue Tao2015-06-083-1/+264
| | | | | | | | Backport two commits from libsndfile upstream to fix a segfault and two potential buffer overflows. Signed-off-by: Yue Tao <Yue.Tao@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* autogen: redirect the log file to build dirRoy Li2015-06-082-1/+31
| | | | | Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* distrodata: Use Python CSV instead of did by handAníbal Limón2015-06-081-61/+65
| | | | | | | | | | | Fix CSV generation in distrodata class using Python CSV module before it some errors happen when read due to incorrect quoting/delimiters. [YOCTO #7777] Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* distrodata: checkpkg make usage of oe.recipeutils.get_recipe_upstream_versionAníbal Limón2015-06-081-47/+37
| | | | | | | Now get_recipe_upstream_version function exists in oe.recipeutils module to avoid duplicate code make usage of it. Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com>
* distrodata: Remove unnecessary include of package_regex.incAníbal Limón2015-06-081-1/+0
| | | | | | | | | | | | | | This causes a warning when follow documentation to use distrodata class that points to include, include conf/distro/include/distro_alias.inc include conf/distro/include/recipe_color.inc include conf/distro/include/maintainers.inc include conf/distro/include/upstream_tracking.inc include conf/distro/include/package_regex.inc INHERIT+= "distrodata" Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com>
* recipeutils: Improve get_recipe_pv_without_srcpv functionAníbal Limón2015-06-081-10/+2
| | | | | | | Use pv instead of rd this make the function more generic and avoid copy recipe data. Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com>
* xkeyboard-config: Upgrade 2.14 -> 2.15Jussi Kukkonen2015-06-082-56/+3
| | | | | | | Drop what remains of the patch the removed some GPLv3 content: both eu and ph layout licenses have been corrected. Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
* xf86-video-vmware: Upgrade 13.0.2 -> 13.1.0Jussi Kukkonen2015-06-082-41/+3
| | | | | | Remove one upstreamed patch. Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
* xf86-video-omap: Upgrade to 0.4.3Jussi Kukkonen2015-06-082-83/+2
| | | | | | | Use last release instead of slightly older git revision, drop the upstreamed patch. Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
* xf86-input-synaptics: Upgrade 1.8.1 -> 1.8.2Jussi Kukkonen2015-06-081-2/+2
| | | | Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
* xf86-input-keyboard: Upgrade 1.8.0 -> 1.8.1Jussi Kukkonen2015-06-081-2/+2
| | | | Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
* xf86-input-evdev: Upgrade 2.9.1 -> 2.9.2Jussi Kukkonen2015-06-081-2/+2
| | | | Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
* python3-pip: Adds recipe for python3-pipAlejandro Hernandez2015-06-081-0/+40
| | | | | | | | | | | PIP is installed by default since python 3.4, due to issues with the autobuilders, its default installation had to be disabled, this creates a recipe for it, it brings a lot of new dependencies so it is chosen not to be installed by default along with python3-core. [YOCTO #7762] Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
* python3-distribute: Upgrade to python3-setuptools 15.2Alejandro Hernandez2015-06-082-19/+23
| | | | | | | | | | python3-distribute was merged back to python3-setuptools in 2013, and it is no longer being maintained, this upgrade also provides functionality that will be needed for python3-pip. [YOCTO #7763] Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
* python3-io: Fixes compilation of python3 ssl moduleAlejandro Hernandez2015-06-082-0/+42
| | | | | | | | | | | During python3 compilation, the module ssl was being skippped due to the fact that the compilation script couldnt find the required files, this patch fixes setup.py so it looks for the files in the correct directory, hence fixing its compilation and installation. [YOCTO #7768] Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
* python3: Fix distutils import errorAlejandro Hernandez2015-06-081-1/+0
| | | | | | | | | | | | | The patch 12-distutils-prefix-is-inside-staging-area.patch is used to fix problems when trying to get some environmental variables but it is only necessary for python3-native, on python3-core it causes an error when importing distutils since env variables of the likes of HOST_SYS and such do not exist on target, this removes the patch from python3-core so distutils can be imported correctly. [YOCTO #7766] Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
* python3: fix pyconfig.h installation on targetAlejandro Hernandez2015-06-082-2/+2
| | | | | | | | | | The file pyconfig.h wasnt being deployed on target, causing an error when importing some libraries that required it, this patch fixes python3 manifest to include this file and fix the issue. [YOCTO #7764] Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
* rpm: remove extra dev and dbg packagesRobert Yang2015-06-081-11/+3
| | | | | | | | | There should be only one dev and dbg package. [YOCTO #7481] Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* lsof: Remove LSOF_OSKhem Raj2015-06-081-4/+1
| | | | | | | | This is not needed since its target recipe and we always need to pass 'linux' for OS Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* libpam: Fix wrong crypt library detectionKhem Raj2015-06-082-2/+35
| | | | | | | | Surfaced when building with musl This details are in patch headers Enabel innetgr.patch for musl as well Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* sgmlspl-native: 1.03ii -> 1.1Robert Yang2015-06-083-476/+20
| | | | | | | | | | | | * The old HOMEPAGE and SRC_URI are not available any more, use github to instead of. * Remove combined.patch since part of them is already in the source (sgmlspl.pl), and part of them are not needed any more (the doc sgmlspl.1, there is a sgmlspl.sgml). Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* cmake: Whitespace fixMoritz Blume2015-06-081-1/+1
| | | | | Signed-off-by: Moritz Blume <moritz.blume@bmw-carit.de> Signed-off-by: Ross Burton <ross.burton@intel.com>
* alsa-tools: add dependency glib-2.0Kai Kang2015-06-081-1/+1
| | | | | | | | Add dependency glib-2.0 for alsa-tools. It is required by new added sub-component hdajacksensetest. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* alsa-plugins: enable alsa-plugins-pulseaudio-conf conditionallyTanu Kaskinen2015-06-081-1/+1
| | | | | | | | | | | | | | | | | | | | If pulseaudio isn't enabled, the alsa-plugins-pulseaudio-conf package is unnecessary. This change fixes these warnings, when pulseaudio isn't enabled: WARNING: QA Issue: alsa-plugins-pulseaudio-conf rdepends on libasound-module-conf-pulse, but it isn't a build dependency? [build-deps] WARNING: QA Issue: alsa-plugins-pulseaudio-conf rdepends on libasound-module-ctl-pulse, but it isn't a build dependency? [build-deps] WARNING: QA Issue: alsa-plugins-pulseaudio-conf rdepends on libasound-module-pcm-pulse, but it isn't a build dependency? [build-deps] Reported-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tanu Kaskinen <tanu.kaskinen@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* qt4: upgrade to 4.8.7Kai Kang2015-06-0844-777/+39
| | | | | | | | | | | | | Upgrade qt4 packages from version 4.8.6 to 4.8.7. * remove arm64 related patches which are merged * remove 0034-Fix-a-division-by-zero-when-processing-malformed-BMP.patch which is backported. * update 0010-configure-Hack-to-not-use-the-pg_config-of-the-host-.patch and 0013-configure-add-crossarch-option.patch for new version * remove useless variable INC_PR Signed-off-by: Kai Kang <kai.kang@windriver.com>
* scripts/combo-layer: Fix exit codes and tty handlingRichard Purdie2015-06-051-3/+7
| | | | | | | | | | If combo-layer is called from a non-interactive context we should exit with a correct error code rather than try and drop to a shell. This patch cleans up a few error case exit codes as well as detecting and handling non-interactive usage. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* xserver-xorg: always enable DRI2 by defaultRoss Burton2015-06-051-1/+1
| | | | | | | | | | | | | DRI2 is more abstract than the original DRI and isn't tied to OpenGL or any other rendering system, and as such is being used by more than OpenGL support in xserver. In particular, the new modesettings driver uses DRI2 to accelerate drawing, so enable DRI2 by default. This was spotted because the "nodistro" DISTRO doesn't enable OpenGL, so xserver failed to build as dri2proto wasn't built. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* linux-yocto: update beaglebone, mpc8315e and edgerouter to 3.19Bruce Ashfield2015-06-052-11/+11
| | | | | | | | Bumping the linux-yocto SRCREVs to integrate fixes for the h/w reference BSPs to the 3.19 kernel. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* dosfstools: Add recipe for v3.0.28Sören Brinkmann2015-06-031-0/+24
| | | | | | | | Add a recipe for building the latest (as of today) version of dosfstools. Signed-off-by: Sören Brinkmann <soeren.brinkmann@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* glib-2.0: 2.44.0 -> 2.44.1Robert Yang2015-06-032-45/+2
| | | | | | | Removed 0001-GListModel-roll-back-use-of-type-redefinition.patch since it is a backport patch. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
* ethtool: 3.16 -> 4.0Robert Yang2015-06-032-53/+2
| | | | | | Removed ethtool-uint.patch since it is already in the source. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
* debianutils: 4.5 -> 4.5.1Robert Yang2015-06-031-2/+5
| | | | Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
* python-nose: 1.2.1 -> 1.3.6Robert Yang2015-06-031-2/+2
| | | | Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
* python-mako: 0.9.1 -> 1.0.1Robert Yang2015-06-031-3/+4
| | | | | | | The LIC_FILES_CHKSUM was changed because the year changed: 2013 -> 2015, the license are the same. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
* liberror-perl: 0.17023 -> 0.17024Robert Yang2015-06-031-2/+2
| | | | Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
* xserver-xorg: Upgrade 1.16.3 -> 1.17.1 (OELAYOUT_ABI change)Jussi Kukkonen2015-06-039-369/+16
| | | | | | | | | | | | | | | | * Increase OELAYOUT_ABI: this is required because the xf86-video-modesetting package moves from its own recipe to xserver-xorg and sanity check cannot handle that currently. The upgrade will delete old xf86-video-modesetting files from sysroots. * Remove upstreamed xserver-xorg patches * Remove xf86-video-modesetting recipe: the driver is now included in xserver-xorg recipe, which now produces the xf86-video-modesetting package. The package version changes from 0.9 to 1.17.1 * Update xserver-xorg license checksum: modesetting license info (another MIT one) has been added to the file Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
* distutils.bbclass: consistency between error message and setup.py's commandMario Domenech Goulart2015-06-031-1/+1
| | | | | | | | setup.py was called with build as argument, but the error message would report build_ext. Signed-off-by: Mario Domenech Goulart <mario@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com>
* libav: upgrade to 9.18Kai Kang2015-06-034-6/+104
| | | | | | | | Upgrade libav from version 9.16 to 9.18. Remove unused var INC_PR and backport patch to fix CVE-2014-9676. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* btrfs-tools: 3.18.2 -> 4.0.1Robert Yang2015-06-032-15/+17
| | | | | | | | | | | * Updated fix-parallel.patch * The 4.0.1 switched to autotools, but inherit autotools doesn't work: | make: *** No rule to make target `ctree.o', needed by `btrfs'. Stop. so inherit autotools-brokensep Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* alsa-plugins: Include missing sys/select.hKhem Raj2015-06-032-1/+34
| | | | | | This is exposed by musl where indirect include does not happen Signed-off-by: Khem Raj <raj.khem@gmail.com>
* binutils: Update to tip of 2.25 branchKhem Raj2015-06-032-2/+2
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | This update brings following patches 749b1c7 Fix some PPC assembler errors. fe1e924 [AArch64][Backport] Remove Load/Store register (unscaled immediate) alias 4e4d08c [AArch64][Backport] Don't always create new frag for .inst directive 0381bf1 [AArch64][Backport] PR18270, fix handling of GOT entry for local symbol bb22a11 [AArch64][Backport]Improve PC-relative relocation check for shared library 699dcf3 opcodes/ e700dd4 Downgrade linker error on protected symbols in .dynbss to a warning 13ccf8a Revert "Add extern_protected_data and set it for x86" b0356a6 Add support for the Samsung Exynos M1 processor. 40dbf9d Add support for the Samsung Exynos M1 processor. 2aa5937 Don't pass unadorned zeros to varargs functions 12aca65 Relax PR 15228 protected visibility restriction b443789 [AArch64] Fix branch stubs for BE ab50ec0 Import fixes from mainline sources that address illegal memory access problems with the ELF targeted parts of the BFD library. a539f2c Import patches from the master sources which fix illegal memory accesses found by running the binutils on fuzzed binaries. a5ebc2c Fix build problem introduced by previous delta to coffgrok.c 7a57494 Import fixes from mainline that address illegal memory accesses when working with COFF/PE based files. 4f9583e Import fixes from trunk sources to correct invalid memory access issues with various binutils programs. 304a2b6 Import fixes for invalid memory access issues in the binutils DWARF parser from the trunk sources. 1dead8a Import security fixes for readelf from the master branch: 3e3feb3 Limit multi-byte nop instructions to 10 bytes f12dd7b S/390: Disable relocation sort against code sections. 846daac Fix ppc32 synthetic symbols when __tls_get_addr_opt stub is generated 7235408 Tweak ppc32 tls_get_addr optimisation 642fe3b PowerPC64 thread-safe stubs not needed for iplt 2791b63 Use dynamic text relocs for protected vars cff59f0 PowerPC64 GOLD: complain on misaligned _DS relocs 20951c8 Fix gold error: hidden symbol '...' is not defined locally 7428be5 [AArch64][2.25] Backport support for Cortex-A72 8093a8b [ARM][2.25] Backport support for Cortex-A72 f7cf878 [ARM] Backport "Skip private symbol when doing objdump" 031994d Add extern_protected_data and set it for x86 Additionally rearranges the local patches in sequence Signed-off-by: Khem Raj <raj.khem@gmail.com>