aboutsummaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
Diffstat (limited to 'scripts')
-rw-r--r--scripts/lib/devtool/upgrade.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/lib/devtool/upgrade.py b/scripts/lib/devtool/upgrade.py
index 77b48f45a7..f2a93b7acf 100644
--- a/scripts/lib/devtool/upgrade.py
+++ b/scripts/lib/devtool/upgrade.py
@@ -81,7 +81,7 @@ def _rename_recipe_dirs(oldpv, newpv, path):
if olddir.find(oldpv) != -1:
newdir = olddir.replace(oldpv, newpv)
if olddir != newdir:
- _run('mv %s %s' % (olddir, newdir))
+ shutil.move(os.path.join(path, olddir), os.path.join(path, newdir))
def _rename_recipe_file(bpn, oldpv, newpv, path):
oldrecipe = "%s_%s.bb" % (bpn, oldpv)