aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-openmax/ptr-array.patch46
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-openmax_0.10.1.bb1
2 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gst-openmax/ptr-array.patch b/meta/recipes-multimedia/gstreamer/gst-openmax/ptr-array.patch
new file mode 100644
index 0000000000..5965bbafbb
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gst-openmax/ptr-array.patch
@@ -0,0 +1,46 @@
+Rename static functions that use GLib naming conventions as one of them
+(g_ptr_array_insert) has now been added to GLib.
+
+Upstream-Status: Pending
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/omx/gstomx_util.c b/omx/gstomx_util.c
+index 423e441..579dbf5 100644
+--- a/omx/gstomx_util.c
++++ b/omx/gstomx_util.c
+@@ -85,7 +85,7 @@ static gboolean initialized;
+ */
+
+ static void
+-g_ptr_array_clear (GPtrArray * array)
++omx_g_ptr_array_clear (GPtrArray * array)
+ {
+ guint index;
+ for (index = 0; index < array->len; index++)
+@@ -93,7 +93,7 @@ g_ptr_array_clear (GPtrArray * array)
+ }
+
+ static void
+-g_ptr_array_insert (GPtrArray * array, guint index, gpointer data)
++omx_g_ptr_array_insert (GPtrArray * array, guint index, gpointer data)
+ {
+ if (index + 1 > array->len) {
+ g_ptr_array_set_size (array, index + 1);
+@@ -394,7 +394,7 @@ g_omx_core_unload (GOmxCore * core)
+ }
+
+ core_for_each_port (core, g_omx_port_free);
+- g_ptr_array_clear (core->ports);
++ omx_g_ptr_array_clear (core->ports);
+ }
+
+ static inline GOmxPort *
+@@ -418,7 +418,7 @@ g_omx_core_new_port (GOmxCore * core, guint index)
+ }
+
+ port = g_omx_port_new (core, index);
+- g_ptr_array_insert (core->ports, index, port);
++ omx_g_ptr_array_insert (core->ports, index, port);
+
+ return port;
+ }
diff --git a/meta/recipes-multimedia/gstreamer/gst-openmax_0.10.1.bb b/meta/recipes-multimedia/gstreamer/gst-openmax_0.10.1.bb
index ea3b66ba8c..4e22f46532 100644
--- a/meta/recipes-multimedia/gstreamer/gst-openmax_0.10.1.bb
+++ b/meta/recipes-multimedia/gstreamer/gst-openmax_0.10.1.bb
@@ -13,6 +13,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24 \
SRC_URI = "http://gstreamer.freedesktop.org/src/gst-openmax/gst-openmax-${PV}.tar.bz2 \
file://gcc_4.6.patch \
+ file://ptr-array.patch \
"
inherit autotools